dtm.de - page formatting changes after ^clicking on image

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
--
minor
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: lvm, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 3; en-US; rv:1.8b4) Gecko/20050916 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 3; en-US; rv:1.8b4) Gecko/20050916 SeaMonkey/1.0a

prerequisites: option to open links in tabs on ^click should be on. (preferenses.navigator.tabbed browsing.open tabs instead of windows for...

ctrl-clicking on a thumbnail image in 'more news' section (middle column) to open linked url in another tab causes the thumnail image directly under the clicked one to jump to the right. 

Whatever may be said about the document markup, the fact that clicking on a link changes the visual page formatting is definitely a bug. Apparently it is caused by the fact that mozilla draws a selection border around the focused image and increases image size by the width of this border which IMHO is wrong - border is a purely navigational aid and its width should never be taken into account.


Reproducible: Always

Steps to Reproduce:
1. Open http://www.dtm.de/index.en.php
2. ctrl-click on the first image in 'more news' section
3.

Actual Results:  
Image directly under the clicked one on moves to the right by about the image width

Expected Results:  
Document formatting should not change

Comment 1

12 years ago
Same problem in OS/2 FF beta 2, but the bug is in the page's poor CSS, not the browser. If your default font size is larger than the usual 16px, the text adjacent to each image spills below the image, and then the problem doesn't happen at all.
Assignee: general → english-other
Status: UNCONFIRMED → NEW
Component: General → English Other
Ever confirmed: true
OS: OS/2 → All
Product: Mozilla Application Suite → Tech Evangelism
QA Contact: general → english-other
Hardware: PC → All
Summary: page formatting changes after ^clicking on image → dtm.de - page formatting changes after ^clicking on image
looks fixed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.