Closed Bug 313525 Opened 14 years ago Closed 11 years ago

RSS feeds not working in L10N Thunderbird(Finnish, Korean,etc.)

Categories

(MailNews Core :: Feed Reader, defect, major)

1.8 Branch
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: ville.pohjanheimo, Assigned: mkmelin)

References

Details

(Whiteboard: [no en-us impact])

The add RSS feeds panel or feeds in general do not work in Finnish Thunderbird (Recent 1.8-branch build by Mozilla.org). Starting TB with a new profile and adding an RSS account works ok. Trying to add a feed only results in an error in JS Console:

uncaught exception: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED)" location: "JS frame :: chrome://messenger-newsblog/content/utils.js :: getSubscriptionsFile :: line 186" data: no]

Additionally, restarting TB blanks the name of the just created RSS account (apparently irrespective of the name).

The Finnish localization passes the compare-locales scripts and there's nothing _obviously_ wrong and that's why i'm a bit lost w.r.t the solution.
Seems to work fine on linux. Tested the 20051011 build. Mac only?
Yes, MacOS X only. Specifying in title summary too now.
Summary: RSS feeds not working in Finnish Thunderbird → RSS feeds not working in Finnish Thunderbird (Mac only)
WFM.

Mac OS X 10.3.9
Tb 1.8branch build version 1.5 (20051026)
Still does not work for me. Similarly with Mac OS X 10.3.9 and *Finnish* Tb 1.8branch build version 1.5 (20051026)

With an old profile that had a working rss-account the feeds do seem to function perfectly thought, except for a possibly related bug I noticed: the headers for RSS feed pages are not shown (this too Mac only).

crot0@infoseek.jp please confirm that this worked for you on a *new* profile.
(In reply to comment #4)
> Still does not work for me. Similarly with Mac OS X 10.3.9 and *Finnish* Tb
> 1.8branch build version 1.5 (20051026)

I retry and it reproduced.
And this problem relates to bug276188.

In Japanese locale, when the following entries are done in localize, it is made by the name with an illegal directory name of "News & Blogs". 
But in Finnish locale, I think that it cannot make directory because this becomes an illegal name.

  locale/fi/messenger-newsblog/am-newsblog.dtd:
  <!ENTITY rss.wizardLongName         "RSS-uutiset ja -verkkopäiväkirjat">

Other languages might be generated in this problem. 
In all OS of Japanese version package, the localize of this resource is provisionally stopped. 
(In reply to comment #5)
>   locale/fi/messenger-newsblog/am-newsblog.dtd:
>   <!ENTITY rss.wizardLongName         "RSS-uutiset ja -verkkopäiväkirjat">
oops...

A correct entry is as follows. 

locale/fi/messenger-newsblog/am-newsblog.dtd:
<!ENTITY rss.hostName               "Uutiset ja verkkopäiväkirjat">
(In reply to comment #4)
> With an old profile that had a working rss-account the feeds do seem to
> function perfectly thought, except for a possibly related bug I noticed: the
> headers for RSS feed pages are not shown (this too Mac only).

Possibly bug 312474.
In Japanese version Windows, this problem occurs by following build. 
It is not a problem of Mac version alone.

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8-l10n/thunderbird-1.5.ko.win32.zip
1.5 (20051025)

Windows XP SP1
Tb 1.5 (20051025) ko-KR locale version
OS: MacOS X → All
Hardware: Macintosh → All
Summary: RSS feeds not working in Finnish Thunderbird (Mac only) → RSS feeds not working in Finnish Thunderbird
Summary: RSS feeds not working in Finnish Thunderbird → RSS feeds not working in L10N Thunderbird(Finnish, Korean,etc.)
So, the problem for now is that poor l10n@ needs to go through all the locales and ensure that everything makes a valid filename on all supported platforms, and for the future someone needs to add a l10n note above that entity, saying what characters not to use?
Flags: blocking1.8rc1?
So some of the locales are using illegal characters in the localized name of the or News & Blogs account name? That's unfortunate. I wonder why they didn't have the same problem with their localizations of 1.0.

Whiteboard: [no en-us impact]
Depends on: 276188
(In reply to comment #9)
> So, the problem for now is that poor l10n@ needs to go through all the locales
> and ensure that everything makes a valid filename on all supported platforms,
> and for the future someone needs to add a l10n note above that entity, saying
> what characters not to use?
> 

Err, not so. Which filenames are valid and which are not likely depends on the 
installed windows version, code page stuff, if there unicode utils installed or
whatnot.

I need more details here, where is the codepath from a entity to a filename?
Does that entity show up in the UI anywhere?
Oh I know why this wasn't a problem in 1.0 because I didn't let localizers localize the RDF file that contained the default name of the RSS account.

Axel this is the string that gets passed in to the mail back end and we end up creating a mail folder with this name unless the user changes the name in the account wizard:

http://lxr.mozilla.org/seamonkey/source/mail/locales/en-US/chrome/messenger-newsblog/am-newsblog.dtd#17

If this name has any illegal folder characters, we'll have problems.
Flags: blocking1.8rc1? → blocking1.8rc1-
We agreed that we need a good fix for this for 2.0, but for 1.5, this needs
to be fixed on the l10n side, by just using a simple name, like just ASCII.

The right fix is going to be to pass the l10n string through the same sanitizer
as the UI-entered string is going through.
Duplicate of this bug: 366497
Blocks: 378361
Hrm. This apparently did not make 2.0. Scott, would we have chance to get a fix in for this for a minor update?

What do we actually do if someone enters an account name by hand that contains illegal characters? Is that busted, too?
Basically, how about fixing mail folder name to ASCII value in fi and ko version rather than waiting for doing code problem? As like Bug 378361.
I changed fi string to ASCII back when this bug was opened, don't know about ko. However, the handling of the strings is still buggy.
Assignee: mscott → nobody
I'm fixing this in bug 364987.
Assignee: nobody → mkmelin+mozilla
Depends on: 364987
Resolved by bug 364987 landing. The name of the data folder isn't taken from a localized value anymore - it's now always "Feeds", "Feeds-2" and so on... (These are internal values never shown in the UI.)

->FIXED
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
Duplicate of this bug: 276188
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 1.5 → 1.8 Branch
You need to log in before you can comment on or make changes to this bug.