Bookmark menu item highlights not drawing completely during first use

RESOLVED WONTFIX

Status

Camino Graveyard
Bookmarks
--
trivial
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: Kevin Parichan, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051017 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051017 Camino/1.0+

The first time the Bookmarks menu is accessed, the menu item highlights don't draw to the end (right edge) of the menu. In some cases, the highlighting remains on a previous highlighted item.

Reproducible: Always

Steps to Reproduce:
1. Launch Camino
2. Use the Bookmarks menu, scrolling through submenus.
3.
(Reporter)

Comment 1

12 years ago
Created attachment 200572 [details]
Screen illustrating the highlight problem

Comment 2

12 years ago
The same thing happens in bookmark folders on the bookmark bar, and (AFAICT) it's caused by the way we're using Carbon events tell when a menu opens so we can assign favicons to to its items on an as-needed basis (instead of all at once on launch). This should be fixed once we drop 10.2 support and move to the Cocoa way of doing this.
So we should confirm this and have it block bug 311840?

Comment 4

12 years ago
Yeah, we should. Sorry about that; reading bugs while half asleep again.
Blocks: 311840
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

12 years ago
This should be fixed when bug 311841 is fixed, so I'm retargeting the blockage.
Blocks: 311841
No longer blocks: 311840
Mass-reassign of bugs still assigned to pinkerton to nobody; filter on "NoMoPinkBugsInCamino".
Assignee: mikepinkerton → nobody
QA Contact: bookmarks

Comment 7

10 years ago
Anyone who can reproduce this should retest once the patch in bug 311841 lands.
No longer blocks: 311841
Depends on: 311841

Updated

10 years ago
Hardware: Macintosh → All
(Reporter)

Comment 8

10 years ago
I reported it, but 2005? That was one machine, processor architecture, and a few OS updates ago. That said, I can't even recall the last time I saw this behavior.
I haven't noticed this on my 10.3 machine since 1.5 shipped, iirc, but I did use to see it often at one point in the past.  Maybe the 10.3 SDK switch suppressed it, though that doesn't really seem likely?
Never mind, I just reproduced it in the all tabs menu in 1.6.1 :P
Can anyone reproduce this on 10.4 in branch builds (or trunk/Cm2 builds from before 11 June), or 10.5/same deal, on a sufficiently slow Mac?

I'm unable to repro this on 10.5 on branch, or trunk before bug 311841 landed, so if no-one else sees this, we should probably close this WFM on trunk.

Comment 12

10 years ago
I don't remember ever having seen this on 10.4, back in the days with the PowerBook, with branch and trunk.
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.