right-click context menu created in drop down menu cannot be dismissed without selecting option

RESOLVED DUPLICATE of bug 231336

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 231336
12 years ago
12 years ago

People

(Reporter: Jonathan Nellis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

If you open a drop down menu as normal, and then right click somewhere in the drop down menu that appears, the typical right-click context menu will appear as if you had right clicked anywhere in the content of the site.  However, the menu cannot be dismissed without selecting an option.  Clicking in another area of the window will not close or even move the menu.  When this menu is open, you can change tabs and click links (with the menu still remaining visible where it was created), but you cannot type anything into the address bar or into any forms.

Reproducible: Always

Steps to Reproduce:
1. Go to php.net.
2. Left click on the drop down menu in the upper right corner.
3. Right click somewhere in that menu, for example, on "whole site".
4. The menu which appears has the characteristics I explained.

Actual Results:  
The right-click context menu appears as normal, however, it cannot be closed without selecting an option from the menu.

Expected Results:  
The right-click context menu should close as is normal under any other cirucumstances.

I haven't tested this on the lastest nightly build.  It is a bug which I have experienced on both of my Macs for as long as I have used Firefox, so I am (maybe stupidly) guessing it didn't go away in the last few weeks.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 231336 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.