If Download Manager is left opened after file download finished, the keyboard arrows and other keys don't work

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Luis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 08/26)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Some keys of my keyboard doesnt work anymore if the download manager is left open after a file download finishes.
When i close the download manager window the bug desapears.
When i see this bug: while browsing with some tables, donwloaded a file, oppened the download window to see the progress, and when the file whas finished, 

Reproducible: Always

Steps to Reproduce:
1. Go to Donloads' Options and uncheck "Show Download Manager when a download begins" and "Close the Download Manager when all downloads are complete".
2. Go to a page that contains files to download (exemple: images).
3. Open the Donwload Manager (Ctrl+j)
4. Donwload a file (example: right click on a image)
5. When the donload finishes, go to the browser window. Some keys (as the arrows) won't work anymore.

Actual Results:  
If you press the keys Home, End, Page Up, Page Down and the four arrows, nothing happens. If you press "'" and "/", the Find Tollbar appears, even if you are writing text on a form.

Expected Results:  
The browser was supose to scrow the page down or up when pressing the direction keys, or move inside a form containing some words.

Default theme.
I unchecked the options:
Show Download Manager when a download begins
Close the Download Manager when all downloads are complete
Summary: If Donwload Manager is left oppened after file download finished, the keyboard arrows and other keys doesn't work → If Download Manager is left opened after file download finished, the keyboard arrows and other keys don't work

Comment 1

13 years ago
Duplicate of/related to bug 312394 -> Core bug 312227?

Comment 2

11 years ago
This WFM with current version

reporter do you still see this in current version?

if fixed please resolve this report as WORKSFORME, thank you
Whiteboard: CLOSEME 08/26
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.