Closed Bug 313795 Opened 17 years ago Closed 17 years ago

Clicking "Get More Extensions" produces javascript error

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 309775

People

(Reporter: arudmik, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Open Extensions window and click Get More Extensions - produces the following error message

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/text.xml :: onxblclick :: line 326"  data: no]

Reproducible: Always

Steps to Reproduce:
1.Open Extensions window
2.Click "Get more extensions"
3.Error message appears in Javascript console
works for me in latest branch

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Sounds like bug 309775, which should be fixed in current nightly builds. Is it always always reproducible, or only always after you've opened 12 popups (both from links, and within the browser UI, including prefs and things like get more extensions)? If you close Firefox completely, and then very first thing open the Extension Manager and click the link, does it work then?
If you close Firefox completely, and then very first thing open
the Extension Manager and click the link, does it work then? I confirmed that the error goes away if I close and open Firefox. In fact I've seen the error where Javascript stops working after opening javascript windows. I will test this with a nightly build.
Did you get around to testing it with a nightly?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/

I'm resolving this as a dupe of bug 309775, because it's /very/ likely to be so, but feel free to reopen if you can still reproduce the problem with the recent nightly build. In that case, please provide the UA string from Help > About window.

*** This bug has been marked as a duplicate of 309775 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.