Access Denied error when I use https going to port 448 with virtual host subdomain of site

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Naomi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

I'm on a team that looks after the website at www.adelaide.edu.au.  We have several virtual hosts on our server, such as commerce.adelaide.edu.au.  Our secure certificate is a wildcard one, for *.adelaide.edu.au, so it *should* cover subdomains such as www or commerce or anything really.
However, when I try to view any page on one of the virtual host subdomains in firefox (on linux) over https, it gets an Access Denied error.  I've tried it in IE (on windows and a Mac), Epiphany (on linux) and Firefox (on a Mac) and it worked fine.
So the common themes for it not working seem to be:
1. firefox
2. linux
3. virtual host subdomain
4. https (it does redirect to port 448 when going to https, so that may actually be the issue)

Reproducible: Always

Steps to Reproduce:
1. go to https://commerce.adelaide.edu.au/ in linux firefox
2.
3.

Actual Results:  
ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: www.commerce.adelaide.edu.au:448

The following error was encountered:

    * Access Denied.

      Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect. 

Expected Results:  
display the page

Comment 1

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051003 Firefox/1.4.1

WFM in Firefox 1.5 beta 2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5 ID:2005102523

WFM too.
This will be a problem with your proxy server / firewall most likely. Most are only set to allow connections to secure servers on port 443 as standard.

Comment 4

12 years ago
-> WFM

If you can reproduce this problem with a current build (and it is not caused by the firewall/proxy settings), please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.