Mail composer does not display color settings when loading a msg from the Drafts folder

RESOLVED DUPLICATE of bug 234354

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 234354
12 years ago
12 years ago

People

(Reporter: John T, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b5) Gecko/20051019 SeaMonkey/1.0b
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b5) Gecko/20051019 SeaMonkey/1.0b

I have tried this with both a recent Seamonkey 1.1 and 1.0 build. The 1.0 build shows text color, but not the background. When loading a msg that should have a background color, I can see the color momentarily shown and then replaced with white background.

In a very recent Seamonkey 1.1 nightly (10-19 maybe), a msg I composed and saved into the draft color showed neither the background nor the text color. Both were set to white background and black text after momentarily showing the background color. I don't know if the text was momentarily shown right or not.

This problem doesn't seem to occur in the Conposer window, so it's specific to mail compose windows.

Reproducible: Always

Steps to Reproduce:
1. Compose a mail message using color text and background
2. Save the message to the draft folder and close it
3. Open the message in the draft folder 
Actual Results:  
In recent Seamonkey 1.0, the text color is shown, but not the background. It's set to default.

In recent Seamonkey 1.1, neither the text nor background color is shown. Both are set to default.

Expected Results:  
The colors should be displayed as they were saved.
(Reporter)

Comment 1

12 years ago
Seamonkey 1.1 (recent) may not save the text color correctly, though Seamonkey 1.0 saves text color ok.
(Reporter)

Comment 2

12 years ago
The code to initialize settings in a message seems to be involved. In the msg saved with Sea 1.0b, the cursor appears to be at the start of the msg. But the format bar shows "variable width" font and green text, though the font is Anastasia. A cursor left doesn't move on the screen, but it turns the text color black. A cursor right moves one char to the right and makes the right font setting appear.

Using Sea 1.1a, one cursor to the right makes the font setting appear. From there, one to the left puts it at the upper right with the font still showing correctly. Another cursor left makes "variable width" appear in the font field.

The "view source" menu item isn't available in items not sent, so it's unclear to me whether the Seamonkey program or the saved file is producing these effects.
(Reporter)

Comment 3

12 years ago
This seems to save text color OK: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051021 SeaMonkey/1.1a, contrary to previous comments.

Text typed at the start of a saved msg has specified color, but default font and size instead of what the saved file specifies.

Comment 4

12 years ago
I can reproduce the default-background-color issue for Seamonkey 1.0a-0910.
With TB 1.5b2 and TB 1.6a1, the background color is preserved -- this is unexpected, as the mail-composition code between the two is largely shared.

(In reply to comment #2)
> In the msg
> saved with Sea 1.0b, the cursor appears to be at the start of the msg. But the
> format bar shows "variable width" font and green text, 

I'm not seeing "green text," I'm seeing default (black), just as you describe for 1.1a.

Either way, this is unrelated to the background-color issue: I also see this happening in Thunderbird, despite the background color being preserved.

The thing here is, when you change the background color, that makes a single change to the <body> of the message.  Changing the text color simply adds a <font> tag that specifies a color, and due to a well-known deficiency in Mozilla's HTML editing, it's easy to get outside of that font tag when you want to be inside it, and vice versa.  This is related to the problem at bug 250539.

> The "view source" menu item isn't available in items not sent

It's not available in the Compose window, but it's available from the 3pane when you select an message in the Drafts or Templates folder.

*** This bug has been marked as a duplicate of 234354 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.