Registration errors of localization of editor and wallet

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: p.franc, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Testing Czech version of TB 1.5 I found these errors in JS console:

Failed to load old-style contents.rdf at
'jar:resource:///chrome/cs.jar!/locale/cs/editor/contents.rdf'.
Failed to load old-style contents.rdf at
'jar:resource:///chrome/cs.jar!/locale/cs/wallet/contents.rdf'.

Editor resource is properly registred via jar.mn in cs.manifest so the localization actually works. There is no /locale/cs/wallet/. The old-style registration in installed-chrome.txt comes IMHO from http://lxr.mozilla.org/mozilla1.8/source/mail/installer/windows/ab-CD.jst#410 and failed because there are no contents.rdf.

Comment 1

13 years ago
I think you can just remove the registration in ab-CD.jst - it shouldn't be necessary. I don't think it matters at all, though.
Severity: normal → trivial
(Reporter)

Comment 2

13 years ago
Created attachment 200867 [details] [diff] [review]
Remove the registration in ab-CD.jst
Attachment #200867 - Flags: review?(benjamin)
Attachment #200867 - Flags: approval1.8rc1?

Updated

13 years ago
Attachment #200867 - Flags: review?(benjamin)
Attachment #200867 - Flags: review+
Attachment #200867 - Flags: approval1.8rc1?
Attachment #200867 - Flags: approval1.8rc1-
(Reporter)

Comment 3

13 years ago
*** Bug 323145 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
I'm puzzled why I'm not seeing this in the en-US build, ab-CD.jst is the same
for all of them, right?
browser's .jst files do have a few registerChrome calls, too, not sure why
those don't trigger those problems.

Comment 5

12 years ago
This bug still exists in current 2.0a1 builds. Only the l10n-installers are affected - not the zip-builds.

Comment 6

12 years ago
Seems to be fixed in Thunderbird 2.0 Beta 2
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.