checksetup.pl error: Can't DROP 'PRIMARY'; check that column/key exists

RESOLVED DUPLICATE of bug 285722

Status

()

RESOLVED DUPLICATE of bug 285722
13 years ago
13 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

2.18.4
x86
Linux

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

checksetup.pl generates this error when upgrading from 2.16.7 to 2.18.4:

The error does not occur if I upgrade directly to 2.20, and upgrading from this 2.18.4 to 2.20 seems to yield a working installation.

Reproducible: Always

Steps to Reproduce:
1. use mysqldump to create a copy of database from the 2.16.7 installation
2. use 'source dump.sql' to initialize a new database
3. point a clean 2.18.4 installation at the database from step (2) and run checksetup.pl

Actual Results:  
DBD::mysql::db do failed: Can't DROP 'PRIMARY'; check that column/key exists at ./checksetup.pl line 3496.


Expected Results:  
No error should be generated.

The dump in step (1) is generated with:

$ mysqldump --version
mysqldump  Ver 8.22 Distrib 3.23.51, for pc-linux-gnu (i686)

The new database is running on:

$ mysql --version
mysql  Ver 14.7 Distrib 4.1.14, for slackware-linux-gnu (i486) using  EditLine wrapper
(Reporter)

Comment 1

13 years ago
Created attachment 200874 [details]
full output from checksetup.pl
Is this perhaps a special case of bug 300452?
(Reporter)

Comment 3

13 years ago
I'm not sure I completely understand that bug (and I haven't taken the time to read bug 285111 or bug 291548).  While I have done some customizations to the 2.16.7 install, I'm pretty sure there wasn't anything that would've changed the DB schema.  If you can give me the relevant mysql command to dump out the schema, I'll be happy to run it.
Ok. It turns out this is a duplicate of bug 285722. The error has been fixed there.

Don't worry about the message you're seeing -- in this particular case, checksetup.pl should be able to carry on without loss.

*** This bug has been marked as a duplicate of 285722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 2.18.3

Comment 5

13 years ago
No, that bug was fixed long before 2.20 was released, so if you're experiencing this bug now, that's a separate bug.

What I'd really like to see is your schema from 2.16.7, from before the upgrade.

You can generate this by doing: 

mysqldump --no-data bugs

And attaching the resulting output.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

13 years ago
Created attachment 200904 [details]
output from 'mysqldump --no-data'
(Reporter)

Updated

13 years ago
Version: 2.18.3 → 2.18.4

Comment 7

13 years ago
Ohh, I see what Marc meant, now. I thought you were reporting this bug against 2.20. Yes, it's true that it's possible this bug went unfixed in 2.18, but it was a major change, and so it could only be fixed in 2.20. It's too major at this point to fix in 2.18.

*** This bug has been marked as a duplicate of 285722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.