Bugzilla pages have no character encoding specified

RESOLVED FIXED

Status

()

defect
P2
normal
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: smjg, Assigned: justdave)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [blocker will fix], URL)

(Reporter)

Description

14 years ago
I've a recollection of the bugzilla.mozilla.org pages validing successfully at some point in the past.  However, now the validator merely reports them as tentatively valid.  This applies to all of the pages I've tried - b.m.o home page, individual bug page, the Enter Bug page, probably the lot.  The validator reports:


No Character Encoding Found! Falling back to UTF-8.

I was not able to extract a character encoding labeling from any of the valid sources for such information. Without encoding information it is impossible to reliably validate the document. I'm falling back to the "UTF-8" encoding and will attempt to perform the validation, but this is likely to fail for all non-trivial documents.
Component: User Interface → Bugzilla: Other b.m.o Issues
Product: Bugzilla → mozilla.org
Version: 2.20 → other
This is actually not a regression per-se, as bmo has never specified a character set except on the enter_bug and createaccount pages, and those were raw hacks that have only been there a couple months.

I was originally planning to go UTF-8 site-wide, but I didn't get the tools in place in time that I needed to pull it off (we have a hell of a lot of legacy data in a dozen or so different charsets).

I'm going to give it another attempt in the next week or so.
Assignee: myk → justdave
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P1
QA Contact: default-qa → myk
Depends on: 313535
Blocks: 313535
No longer depends on: 313535
No longer blocks: 313535
Depends on: 313535
(Reporter)

Comment 2

14 years ago
Any particular reason that this isn't an HTML validation issue?
Assignee: justdave → justdave
Priority: P1 → P2
(In reply to comment #2)
> Any particular reason that this isn't an HTML validation issue?

It is an HTML validation issue.  But that doesn't make it any easier to fix.
Blocks: 335151
No longer blocks: bmo-upgrade-051022
*** Bug 353833 has been marked as a duplicate of this bug. ***
No longer blocks: 335151
Depends on: 335151
No longer depends on: 313535
Whiteboard: [blocker will fix]
Woot, utf8 param is now on! :)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
QA Contact: myk → reed
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.