with embed and a plugin, if the src= url is not valid, this is never communicated to the plugin

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
13 years ago
5 years ago

People

(Reporter: No one public, Unassigned)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

It looks like the 
nsPluginStreamListenerPeer::OnStartRequest bails out early if the request is bad

when nsPluginStreamListenerPeer::OnStopRequest is called

  mPStreamListener = 0 and this bails out and no notification is done
  if(!mPStreamListener)
      return NS_ERROR_FAILURE;


Reproducible: Always

Steps to Reproduce:
set up an embed that will call mplayerplug-in
with a bogus but well formed url for the src=URL field
Note that there is no error indication and NewStream/DestroyStream are never called in the plugin



When the src=URL is valid, NewStream is called on the plugin
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.7 Branch
Firefox 1.0.7 is obsolete. Does this still happen with a current build (which version?) of Firefox or SeaMonkey?

Comment 2

5 years ago
I cannot think how we would do this differently given the current NPAPI, so I'm going to WONTFIX this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.