If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"text-transform: uppercase" truncates strings containing ß or �

RESOLVED DUPLICATE of bug 96423

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 96423
12 years ago
12 years ago

People

(Reporter: Robert Wetzlmayr, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Uppercasing ß and ß results in an expansion of the string by one character as ß is transformed into "SS". Gecko expands the surrounding box but does not render the whole string.

Reproducible: Always

Steps to Reproduce:
1. apply "text-transform: uppercase" to a string containing either a &szlig or a ß


Actual Results:  
String is truncated by one character as it is not accounted for the "SS" which results from uppercasing ß

Expected Results:  
Expand string size by one, render all characters.

HTML test case:

<body>
<p>
<span style="text-transform: uppercase; border: 1px solid red;">Haß</span>
<span style="text-transform: uppercase; border: 1px solid red;">Mi&szlig;gunst</span>
</p>
<p>Haß, Mi&szlig;gunst</p>
</body>

Comment 1

12 years ago
Created attachment 200962 [details]
reporter's testcase

Comment 2

12 years ago
Works for me in trunk nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051026 Firefox/1.6a1).  Can you test with Firefox 1.5 beta?
Version: Trunk → 1.7 Branch
This is indeed fixed in trunk and 1.8 branch.

*** This bug has been marked as a duplicate of 96423 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Summary: "text-transform: uppercase" truncates strings containing &szlig; or ß → "text-transform: uppercase" truncates strings containing &szlig; or �
You need to log in before you can comment on or make changes to this bug.