bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Possible DoS function with the use of | to spawn multiple tabs.

VERIFIED DUPLICATE of bug 221445

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 221445
13 years ago
13 years ago

People

(Reporter: mentality, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

It appears if you use an external program to launch Firefox with the url above, FF will spawn with numerous tabs. In which case it will cause the browser to consume more cpu, memory, along with making the browser unable to close until you satisfy all dialogs that pop up saying 'document cannot be found' or some where along those lines.

The program which i used to spawn firefox was mIRC by double clicking said URL. It does however not have an effect if you actually cut and paste the URL into the address bar. 

It may be a 'feature' as it would, to a select few, be usefull to spawn multiple tabs at once, but for the majority it's pretty useless, and as you can see, it can be abused; DoS, Spam type Popups even..

Reproducible: Always

Steps to Reproduce:
1.Pasted said URL above in to mIRC
2.Double clicked it to spawn Firefox
3.

Actual Results:  
Several tabs were opened.

Expected Results:  
The browser should not interperate | as an indicator to open a new tab.

*** This bug has been marked as a duplicate of 221445 ***
Group: security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.