Camino crashes ("no suitable image found") loading PDF content with Adobe plugin

RESOLVED WORKSFORME

Status

Camino Graveyard
Plug-ins
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Joshua Eisenman, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051027 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051027 Camino/1.0+

Link (dyld) error:

no suitable image found.  Did find:
	/Library/Internet Plug-Ins/AdobePDFViewer.plugin

Reproducible: Sometimes

Steps to Reproduce:
1.open apple Q
2.navigate apple support discussion boards (adobe acrobat file)
3.




Using phoenix optimized build for g4 powerbook
(Reporter)

Comment 1

13 years ago
Created attachment 201059 [details]
mozconfig file used to build

Here is the mozconfig file used.

Comment 2

13 years ago
Please try to reproduce with official nightly. Optimised builds should not be used as the basis for reporting bugs.

cl
(Reporter)

Comment 3

13 years ago
Thats what i told sam, but he said to file the bug.  i cant reproduce it in the nightly and it only happens occationally in the optimized build.
Joshua, I assume you're using GCC4? Do you know of other optimized nightlies that are seeing this (other than your own, of course)?

Chris, I asked him to file this. We need to watch out and make sure there aren't bugs associated specifically with GCC4 so if/when we make the switch there won't be major crashers. This is NOT REPRODUCIBLE in the official nightlies.

CCing mento... Is there any way this could be caused by GCC4 vs. GCC3.3?
(Reporter)

Comment 5

13 years ago
My builds are gcc 4.0 and xcode 2.1.  I asked in the forum if their are anyone else experiance this event and directed them here.
(Reporter)

Comment 6

13 years ago
Created attachment 201064 [details]
crash report
(Reporter)

Comment 7

13 years ago
Created attachment 201066 [details]
crash report
That second crash report is after removing the "bad" plugin. Better steps to reproduce (from Joshua):

1. Open Camino
2. Surf to support.apple.com
3. Select the "discussion" section
4. Login using the login link

After logging in, this should crash.

I haven't been able to reproduce with my GCC4 tinderbox build.
Summary: general crash during operation/quit → Crash during operation using GCC4 optimized build
Attachment #201064 - Attachment is obsolete: true
Version: unspecified → Trunk

Comment 9

13 years ago
I don't get it.  Joshua, can you reproduce either crash on your own computer with an official build?

For plugin-related crashes, see whether removing (or moving aside) ~/Library/Application Support/Camino/pluginreg.dat changes anything.
Version: Trunk → unspecified
(Reporter)

Comment 10

13 years ago
I cant reproduce it in a nightly and i am currently building a dist clean build. will see if that fixes it.

Comment 11

13 years ago
The two crashes here are distinct.  I'm making this bug about the plug-in crash.  The crash at Apple's Discussions site in nsPropertyTable::DeleteAllPropertiesFor is covered in bug 314075.
Summary: Crash during operation using GCC4 optimized build → Camino crashes ("no suitable image found") loading PDF content with Adobe plugin

Updated

13 years ago
Attachment #201064 - Attachment is obsolete: false

Comment 12

13 years ago
I haven't tested with Adobe's PDF plugin.  I use (and prefer) Schubert's.  Is anyone else able to reproduce a crash with the Adobe PDF plugin?  If not, this gets WFMified.
WFM per Joshua...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.