Closed Bug 314112 Opened 19 years ago Closed 19 years ago

context menu stays after selecting "save link as"

Categories

(Firefox :: Menus, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 305970

People

(Reporter: bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

When I right-click on a link and select "save link as" the context menu for the link does not go away and overlaps the dialog box where I enter the location to download to. It seems to only happen for the first time you use "save link as."

Reproducible: Always

Steps to Reproduce:
1. Go to a page with files to download http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ for example.
2. Right click one of the links
3. Select "Save link as"

Actual Results:  
The context menu does not go away.

Expected Results:  
The context menu should disappear.

The problem seems to go away after the first download.
No problem here. Windows only?

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Sorry, nevermind the windows question. :)
> No problem here. Windows only?
> 

Hmm, did you try downloading something immediately after launching firefox? The problem seems to resolve itself after you try to download something the first time, so if you used an instance of firefox that had been open for a while it probably wouldn't show the problem.

Or maybe my linux install is to blame. I'm using mandriva 2006 with kde 3.4.2 and whatever the latest Xorg is.

I created a new profile (mkdir /tmp/x ; firefox -profile /tmp/x), the 1.5b page loads, then pasted the ftp url and right click (win32.complete.mar) -> save as.

Does this happen whenever you run start firefox or just for the first run after an upgrade? Could this be gtk2-specific? I'm using 2.6.10-1 (unstable debian) and cannot reproduce at home or work.

Sorry for the late reply, forgot to cc myself. :P
> Does this happen whenever you run start firefox or just for the first run after
> an upgrade? Could this be gtk2-specific? I'm using 2.6.10-1 (unstable debian)
> and cannot reproduce at home or work.

It happens any time I use firefox, but only for the first thing I try to download. After I download one thing, the problem is fixed until I close firefox and open it again. I hope that makes sense.

Are you using gnome or kde? I think my problem might be because I am using kde, and firefox is built with gtk. 
(In reply to comment #5)
> Are you using gnome or kde? I think my problem might be because I am using kde,
> and firefox is built with gtk. 

I'm using Openbox 3. I suppose it's possible that there's a window manager issue, but that seems unlikely. I was thinking that gtk may be to blame, a bug in your version or something...
Now that I think of it, this did come about around the same time I upgraded to mandriva 2006. So you're probably right about it being a gtk problem. 

I think I will go ahead and mark this bug invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
A lot of people are seeing this lately, this is tracked in bug 305970. So, I'm reopening and duping against that bug (which doesn't mean that it's not a gtk issue, it just indicates that futher investigation is needed).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 305970 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
This bug is replicable on Ubuntu Breezy running under Gnome, Firefox v1.5.

Same problem here, Fedora Core 4, firefox 1.5
You need to log in before you can comment on or make changes to this bug.