If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

First launch page (product page) is shown again if Firefox crashes during first session

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
a year ago

People

(Reporter: marcia, Unassigned)

Tracking

1.5.0.x Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [notacrash], URL)

(Reporter)

Description

12 years ago
Seen using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5.

STR:

1. Create a new profile and launch Firefox.
2. Make Firefox crash.
3. Restart Firefox.

Firefox shows the first launch page again (www.mozilla.org/products/firefox/beta2.html) instead of your home page.  This happens regardless of whether you home page was imported, or default. Pressing the home button did take me to the correct place.

I also added bookmarks and other preferences, but these were retained after the crash.

Seen using both Windows XP and Mac
Presumably this occurs because the pref indicating that we've displayed the "first launch" page isn't being written to disk if Firefox isn't properyly shut down. I suppose it would be possible to savePrefFile right after that pref is set, but there are other "state" prefs that this could happen with, I'm not sure it's worth fixing them all. I don't think the odds of this happening and the user impact is that great, especially considering everything else that could go wrong after a crash.

Comment 2

12 years ago
How is it that this pref change is not written to disk even though subsequent pref changes (such as number of days to keep history) are written to disk?
I don't know, my comment was speculation as to the cause. If other prefs are being correctly saved, maybe I was wrong and something else is going on. I'm not currently able to reproduce, let alone debug. A few dump()s in needHomepageOverride would help in understanding what's happening.

On second thought, seems like the pref dialog calls savePrefFile onaccept, so if you were changing other prefs my previous comment probably is wrong.

Updated

8 years ago
Whiteboard: [notacrash]
James, can you test - does this reproduce for you?
Flags: needinfo?(jamesrome)

Comment 5

a year ago
As of late, Firefox never crashes, so I can't test it. Thunderbird crashes all the time, however Wayne.
Flags: needinfo?(jamesrome)
(In reply to James Rome from comment #5)
> As of late, Firefox never crashes, so I can't test it. Thunderbird crashes
> all the time, however Wayne.

James, the Nightly Tester Tools add-on (https://addons.mozilla.org/en-US/firefox/addon/nightly-tester-tools/?src=ss) has the ability to force a crash in Firefox.

Comment 7

a year ago
I get about:session restore
thanks for testing
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.