Pages opened from Google image search do not appear in history (even after clicking "Remove Frame")

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: nixon049, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

When performing a Google image search, the search results pages from images.google.com show up in the History pane as expected. However, if "remove frame" is clicked for an image search result, the page loaded does not show up in History, even if forcing a page reload. Links from that initial page do appear in History.

Reproducible: Always

Steps to Reproduce:
1. Perform Google image search
2. Click on a search result and check History: Google page (with frame) appears in History.
3. Click "Remove Frame" and check History: Current page does not appear in History.

Actual Results:  
Pages loaded by clearing frame in Google image search do not appear in History. Page cannot be "forced" to appear by reloading.

Expected Results:  
All pages loaded should appear in History, even if loaded into a frame.

Comment 1

13 years ago
Reproducible with Mozilla 1.7.12, Mozilla 1.8b1 and SeaMonkey 1.0a.

Comment 2

13 years ago
This works for me in a March 28 Firefox branch nightly using Places.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.0 Branch
No response from reporter re: comment 3 -->INCOMPLETE.
Reporter, if you still see this problem with the latest release of Firefox 2, please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

12 years ago
Still seeing this bug in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4 ID:2007051502. Marking as reopened.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
I'm not sure if we will fix this for fx 2.0.0.x, but we can investigate for the trunk (fx 3).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: CLOSEME 06/27
Summary: Pages opened from Google image search do not appear in history → Pages opened from Google image search do not appear in history (even after clicking "Remove Frame")

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks

Comment 7

10 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Status: NEW → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.