focus extends to edge of viewport when links use absolute position, display:block and image replacement (negative text-indent)

RESOLVED DUPLICATE of bug 303264

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 303264
12 years ago
12 years ago

People

(Reporter: Darren Rigby, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Before 1.5 Beta 1, focus was correctly drawn around a link where an image replaces text hidden by negative text-indent (i.e. Focus followed width and height of the background image. In 1.5 Beta 1 and 2 focus extends to left-hand edge of viewport (probably following css declarations such as text-indent:-700em.

I have reproduced this on several pages which use the image replacement technique in navigation, including mozilla.org, zeldman.com and a site I maintain.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.zeldman.com/ and hit tab two or more times
2. hit tab two or more times
3. Observe link focus
4. Repeat at http://www.mozilla.org/...

Actual Results:  
Link focus starts at edge of viewport window

Expected Results:  
Link focus should concern the width and height of the replaced image

Comment 1

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1

I see this on trunk.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20051028 Firefox/1.5

I've been seeing this behaviour for a long time.

Another example would be http://www.shauninman.com
See:
 - `in partnership with...'
 - `shauninman.complete'
 - the tab for the nav/search bar

Comment 3

12 years ago
Duplicate of bug 303264?
(Reporter)

Comment 4

12 years ago
Ok, the behaviour I describe is the same as in bug 303264 quoted previously, I searched for this behaviour but didn't come across that one unfortunately.

However, for me, this did not not happen with versions prior to 1.5 Beta. In 1.0.7 focus was drawn around the background images without extending left according to the negative text-align. I suppose the browser is acting correctly in outlining links which are theoretically off the possible screen space but I posted this because it didn't happen before. I'm not a developer so I'll leave it with you guys.

*** This bug has been marked as a duplicate of 303264 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.