View->Page Style should have selection for userContent.css

RESOLVED WONTFIX

Status

()

Firefox
Menus
--
enhancement
RESOLVED WONTFIX
13 years ago
5 years ago

People

(Reporter: jonathan chetwynd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

It might help adoption of userContent.css by novices, if it was easier to access and load.

currently even when present this file isn't available as a switch option.

Would it be possible to create a series of approximate styles to suit some needs and provide these as radio options? 

tick box may be the wrong analogy as cascading may be hard to predict for many users.

Reproducible: Always

Steps to Reproduce:
1.create a file userContent.css 
2.save to ~/Library/Application Support/Firefox/Profiles/xyzxyzox.default/chrome
3.or elsewhere (this aspect specific to os x)

Actual Results:  
open menu: View: Page Style: not listed as radio

Expected Results:  
open menu: View: Page Style: listed as radio, with a range of other useful possibilities

"The CSS specification recommends that browsers allow the user to selectiviely turn style sheets on and off." Lie & Bos pg299

http://www.w3.org/TR/CSS1#css1-conformance
(Reporter)

Comment 1

13 years ago
http://www.howtocreate.co.uk/userStyle.html

describes the methods users can load personal style sheets on a variety of user agents.

Mozilla/Firefox is evidently the least user friendly! providing no method to load style sheets from the menu bar.

Comment 2

13 years ago
Related to Suite bug 132506?
I cannot find a dupe. So confirming for now. David, is this a valid request we should consider?
Severity: normal → enhancement
Summary: View: Page Style does not list userContent.css → View: Page Style should list userContent.css
Version: unspecified → 1.5.0.x Branch
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: DUPEME → [CLOSEME 2010-07-30] DUPEME
Duplicate of this bug: 455702
(In reply to comment #3)
> I cannot find a dupe. So confirming for now. David, is this a valid request we
> should consider?

Forgot to confirm. Doing that now. Still waiting for an answer from dbaron. Also cc'ing bz for input.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [CLOSEME 2010-07-30] DUPEME
It's a valid request, though I'm not sure how useful or important it is.
(Reporter)

Comment 8

8 years ago
Safari: preferences, advanced, stylesheet, file search box
Opera: preferences, advanced, content, style options, file search box

this is an accessibility benefit, particularly used by people with reading difficulties.

User Agent Accessibility Guidelines 1.0
Guideline 4. Ensure user control of rendering
http://www.w3.org/TR/WAI-USERAGENT/guidelines.html#gl-user-control-styles

Please read, as there is rather more than this:

"Ensure that the user can select preferred styles (e.g., colors, size of rendered text, and synthesized speech characteristics) from choices offered by the user agent. Allow the user to override author-specified styles and user agent default styles.

Providing access to content (see guideline 2) includes enabling users to configure and control its rendering. Users with low vision may require that text be rendered at a size larger than the size specified by the author or by the user agent's default rendering. Users with color blindness may need to impose or prevent certain color combinations."

The UAAG is intended to be read, understood and implemented by browser developers.

Comment 9

8 years ago
Comment 8 really ought to be its own bug; note that other browsers put this in the prefs and not in a menu. That seemed different enough that I didn't want to re-purpose this bug for it, though. I've tweaked the summary a little so that this makes sense, but I don't see any logical way to implement it, personally. There's a reason every browser that does this puts it in the prefs and not in the menus :-p
Summary: View: Page Style should list userContent.css → View->Page Style should have selection for userContent.css
Version: 1.5.0.x Branch → unspecified
(In reply to jonathan chetwynd from comment #0)
> It might help adoption of userContent.css by novices, if it was easier to
> access and load.

Helping the adoption of userContent.css isn't a current goal. There are add-ons that enable that level of tweaking.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.