Address bar URL completion could search bookmark names

RESOLVED DUPLICATE of bug 278747

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 278747
13 years ago
10 years ago

People

(Reporter: Ihar 'Philips' Filipau, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

From <https://bugzilla.mozilla.org/show_bug.cgi?id=162450>: "Address completion could search bookmarks and thus become bookmark completion or another way to select a bookmark."

The enhancement request is filed for Camino. This is refile for Firefox.

Reproducible: Always

Steps to Reproduce:
1. Add bookmark for example for "http://www.debian.org/News"
2. Wait N days/months for completition history to expire
3. Start typing "debian" in address bar

Actual Results:  
Nothing happens. One has to type complete address to get to debian.org/News.

Expected Results:  
Ff should give as a completition suggestions "www.debian.org/News" (from bookmark) & "www.debian.org" (host name from bookmarks).

Very very convenient feature found in Apple's Safari.

Comment 1

13 years ago
Move to Core -> Location Bar? That would cover both in one bug.
Something like the Automarks extension?
https://addons.mozilla.org/extensions/moreinfo.php?id=404
It is not yet compatible for 1.5 I see.
(Reporter)

Comment 3

13 years ago
I'm already on 1.5b2 so I cannot try the Automarks extension.
I can judge from its description that it requires some user interaction thou.
If the extension can be made to populate completion history automatically with info found in bookmarks, that would do the trick too.
This is a working version: http://www.wyger.nl/usr/carduelis/AutoMarks_0.1_trunk.xpi
It does not update history automatically. 

*** This bug has been marked as a duplicate of 278747 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Sorry, not bug 278747, much as I wanted it to be: that's URLs, this is names. Also not bug 249468, which is keywords, not names, and not URLs. I think with this, we'll have every single part covered, unless someone decides to ask for bookmark descriptions in autocomplete.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Er, at least I assumed from the summary it was, though the example in comment 0 is rather ambiguous with a bookmark to debian.org named Debian.

Comment 8

11 years ago
Bug 278747 has now been morphed to cover bookmark names as well as URLs (new summary is: 'Include bookmarks url's and titles in auto-complete url feature'), has blocking flag and is targeted for M11; can this bug be duped to that one?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago10 years ago
Component: Bookmarks & History → Location Bar and Autocomplete
QA Contact: bookmarks → location.bar
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 278747
You need to log in before you can comment on or make changes to this bug.