javascript consumes plenty of memory and causes crash

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Sami Kerola, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Problem occurs with version 1.0.7 and 1.6a1 on my linux. Couple of friends tested the page, some XP firefoxes crashed others didn't.

I found that java script on web site which keep crashing my browser and I track down various java script includes which ended to code block which is on my home page. I don't why script is being wrote but it seems to cause problem.


Reproducible: Always

Steps to Reproduce:
1. Click url http://personal.inet.fi/atk/kerolasa/evil4firefox.html
2. Wait for crash, with my slow box it takes 10 seconds.

Actual Results:  
Firefox crashes, X window losts icons, toolbar etc and X must be restarted.

Expected Results:  
Perhaps stop running java script before it breaks browser. After all that seems to be mostly useless script, so it should not matter if its not ran till end.

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1

I get an error popup on the test url:
"TypeError: documents.scripts has no properties"

No crash after 1 minute.

Comment 2

13 years ago
(In reply to comment #1)
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1
> 
> I get an error popup on the test url:
> "TypeError: documents.scripts has no properties"
> 
> No crash after 1 minute.
> 

Same here on Windows (Gecko/20051026 Firefox/1.5).

Comment 3

13 years ago
Sami, the script is throwing an error for us and that's why we're getting the alert and not the script that crashes us. Could you fix the script so it doesn't give us the error anymore?
Component: JavaScript Console → General
QA Contact: javascript.console → general
Version: unspecified → Trunk
no response from reporter , resolving INVA
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.