in URLs non-latin1 characters are changed to utf

RESOLVED DUPLICATE of bug 284474

Status

()

defect
RESOLVED DUPLICATE of bug 284474
14 years ago
14 years ago

People

(Reporter: tsakiris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

In the page I give above you can see this happening.
At the center/bottom of the page you can see some links on which the URL contains some greek characters. When I move the mouse over those link I can see those characters correctly displayed on the status bar. But when I follow one of these links, the URL in the location contains these characters converted to their unicode equivalents. This causes the page not to work.


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.e-shop.gr/PER_monitors.phtml
2. Click on "Touch screen" (at the middle bottom of the page).
3. Look at the location bar. Greek chars has been converted to unicode.

Actual Results:  
The page was not working because it needs input not to be in unicode.

Expected Results:  
Leave those characters untouched and use the URL as is.

Comment 1

14 years ago
I can see this Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1

However, are you sure the conversion to unicode is actually what causes the touchscreen page not to work ? For example, if I click on the 17"TFT link which also contains greek characters, I get to a selection of 17" LCD screens.

*** This bug has been marked as a duplicate of 284474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.