Can't print more than 1 page to networked HP LaserJet from Firefox 1.5b2

RESOLVED DUPLICATE of bug 178554

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 178554
13 years ago
13 years ago

People

(Reporter: thul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I have a networked HP LaserJet 6L, connected to a Windows PC and shared over a wireless network that I use on my Mac PowerBook laptop.  Mac OS X Tiger (10.4.2) has drivers for the printer, and it works fine except in Firefox.

In Firefox, anything that I try to print beyond page 1 does not print.  For instance, if I print 1 6-page web page, only 1 page comes out.  If I set it to  print only page 2 (by specifying pages 2 to 2), nothing prints.  If I print to PDF, the same thing happens.  However, this issue does not happen in Safari or any other application - just Firefox.  I've checked my printer settings and what pages I've specified to print, and everything looks fine.  I'm running a fairly-stock (no unusual software) Mac OS X 10.4.2 with all updates using only printer drivers built-in to the OS.

Reproducible: Always

Steps to Reproduce:
1. Configure networked HP PCL-based LaserJet to print on Mac (I'm not sure if it's limited to this type of printer, but this is what I'm having the issue with)
2. Try to print a multi-page document in Firefox

Actual Results:  
Only the first page printed.

Expected Results:  
All pages should have printed.

This has happened since I got the computer with all versions of Firefox 1.0 and up.
(Reporter)

Updated

13 years ago
Severity: major → normal
(Reporter)

Comment 1

13 years ago
Apparently, this issue only occurs on some websites, and varies as to how bad it is.  On some sites, the printout is only partially messed up, while on others all pages except for the first are missing.  Unfortunately, the page on which I encountered this issue was a private, secure page.

Comment 2

13 years ago
Well, a testcase where you see it does not work would be really good :)...
(Reporter)

Comment 3

13 years ago
OK - I have an example.

If I try to print the page http://www.leoville.com/ , only 1 page is printed and it does not contain everything on the page.

This issue, overall, seems to happen most with web pages that have frames (of which leoville.com is one of).

Comment 4

13 years ago
Ok, this is a dupe, too bad this type of bug (printing with frames being broken when more than one page) already exists for many years...

*** This bug has been marked as a duplicate of 178554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.