Closed Bug 314287 Opened 15 years ago Closed 15 years ago

Change default setting for mousewheel.withmetakey.action

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: englabenny, Assigned: mark)

Details

(Keywords: fixed1.8.0.1, fixed1.8.1)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051022 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051022 Camino/1.0+

Since just some week back, there is a new default for the the mousewheel.withmetakey.action setting.

Reproducible: Always

Steps to Reproduce:
1. Press and hold the command key to prepare for opening several links in tabs
2. Accidentially or mindlessly scroll with mouse or trackpad

Actual Results:  
Text size changes, sometimes just as a delay before a clicked link is loaded (if the command key is released just before the link click)

Expected Results:  
It shouldn't be this easy to accidentally resize all text on the page.

Notes: I experience this mainly with my trackpad, not my scrollwheel. Lots of macs have a nice double-finger scroll feature, that makes it even easier to do this by mistake.

Also, scrolling can be imprecise when resizing text, especially with the lag of a large page. This makes it even more annoying as it can be hard to get back to exactly the default font size. (Camino also doesn't have a "Normal font size" menu option to go with all the possibilities for resizing the text)
I forgot some things, of course.
I suggest that the default key to resize text should be option, not command. It would (perhaps) be more discoverable for a user, too.

Sidenote: filed bug 314289 about the "normal text size" menu item.
Mark changed this, I think.  What did the defaults use to be, and why were they changed?
See bug 314250.  I'll change this for Camino for sure, but I want to see if there's a consensus on the other bug so I can keep the mappings the same.
Assignee: mikepinkerton → mark
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 314250 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Is this really a dupe? I thought they had different implementation points. Mark?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #201309 - Attachment is obsolete: true
Comment on attachment 201310 [details] [diff] [review]
Puts text size on ctrl and history on option

Lots of users are complaining that they browse with the command key held and are inadvertently resizing text when operating the mouse wheel.  This patch makes the defaults hopefully less offensive.
Attachment #201310 - Flags: review?(sfraser_bugs)
(In reply to comment #8)
> (From update of attachment 201310 [details] [diff] [review] [edit])
> Lots of users are complaining that they browse with the command key held and
> are inadvertently resizing text when operating the mouse wheel.  This patch
> makes the defaults hopefully less offensive.

What about people who keep the control key down (e.g. for context clicks) and suddenly find this patch causing them to go back in history? Can we keep everyone happy?
(In reply to comment #9)
> What about people who keep the control key down (e.g. for context clicks) and
> suddenly find this patch causing them to go back in history? Can we keep
> everyone happy?

That's what I'm trying to do!  Control does history now, and nobody's complained about that key, only about command.  Control is being moved to text size here.

Considering the nature of contextual menus, I'd be surprised if people were scrolling around with control held down in the same way that they'd have command down.  And aside from the new touchpads and the mighty mouse with default mappings, most hardware that's got a wheel also has a mouse button dedicated to contextual clicks.
Not mentioned, but as we know all key equivalents use command. This has interfered with scrolling a few times for me too.

Reproduce: Scroll down a page, decide you want to reload it. Hitting Cmd-R there is a chance that your other hand hasn't lifted from the trackpad, and you resize the text.
I just checked similar behavior in for Firefox on the trunk: control=size, option=history, command=line at a time.  I didn't want to map command to anything in Firefox and still don't want to map it to anything in Camino.
Simon, got any strong preferences here?  We've only had complaints from command-holders about text size.
Comment on attachment 201310 [details] [diff] [review]
Puts text size on ctrl and history on option

Sure.
Attachment #201310 - Flags: review?(sfraser_bugs) → review+
Mark, any reason this hasn't been checked in yet?
Yes.  I've been under a rock.  I'll crawl out tomorrow.
Fixed on the trunk and a pair of branches.
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.