Add a "Normal Text Size" menu item

RESOLVED DUPLICATE of bug 181712

Status

Camino Graveyard
Toolbars & Menus
--
enhancement
RESOLVED DUPLICATE of bug 181712
12 years ago
12 years ago

People

(Reporter: Ulrik Sverdrup, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.5
PowerPC
Mac OS X

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051022 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051022 Camino/1.0+

Camino has no easy way to get back to the normal text size of a rendered page, once the user has used the Bigger/Smaller Text menu items or the scroll wheel (with modifier) to change the display size.

Reproducible: Always

Steps to Reproduce:
1. Resize the page text several steps
2. Try to get back to the original size

Actual Results:  
You have to reverse any actions you have taken.

Expected Results:  
There should be a "Normal Text Size" menu item, to get a fast way to get back to the default state.

One of the especially irritating small quirks it that scroll wheel resizing and menu item resizing (cmd-+ or cmd--) use different step sizes. So the method with the larger step size (the menu items) often can't get back to the original size.

The problem is maginified by the fact that it's hard and imprecise to try to resize text with the scroll wheel. (It might depend on the layout of the page, and the lag when resizing)
I swear we have a bug on this already, but I can't find it.  I think this is a good idea, especially since increasing the font size is preserved through page loads (which itself is a good thing for accessibility reasons).  Firefox, iCab, and IE all have this (or an analagous feature), too.  ("Normal" really should take the Cmd-= shortcut, too, so that bigger is Cmd-+ to match smaller.)

(In reply to comment #0)
> One of the especially irritating small quirks it that scroll wheel resizing and
> menu item resizing (cmd-+ or cmd--) use different step sizes. So the method
> with the larger step size (the menu items) often can't get back to the original
> size.

Probably deserves its own bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino1.1

*** This bug has been marked as a duplicate of 181712 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.