If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

download manager only downloads 2 concurrent files at a time. This should be user configurable.

RESOLVED DUPLICATE of bug 156743

Status

()

Core
Networking: HTTP
--
major
RESOLVED DUPLICATE of bug 156743
12 years ago
12 years ago

People

(Reporter: 5chumwaY, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

open a web site with multiple large downloads (ie many files to be downloaded in excess of 2-3M).
When I right click and "save link as" it will start downloading the first file. I do this same process again to start a second file downloading. Upon the 3rd attempt of this there is no action... until one of the first 2 downloads complete then the window pops up asking where I want to save the file. It can only download 2 files at a time. This should be user configurable and a simple option to change. I have tried some of the settings I have found on the web but no mention of how to increase the number of concurrent downloads.

Reproducible: Always

Steps to Reproduce:
1. go to a site with multiple large items to download
2. download 3 items before the first 2 complete
3. 3 item does not prompt for save location nor does it start downloading until one of the first two are complete

Actual Results:  
no action/response from browser until one of the first 2 complete. If you have 20 items to download this is worth changing browsers for!!!!

Expected Results:  
should be able to specify how many concurrent downloads are requested. If you select to have 10 concurrent downloads then download manager would start up to 10 concurrent downloads. Also, if you start an additional one before the others complete there should be a pop-up saying the max number of concurrent downloads has been exceded please wait until one of the downloads completes or increase the number of concurrent downloads <link to setting>

ARRRRRGGG!

Comment 1

12 years ago
This is a limit of the networking code, not the download manager.  The idea is to play nicely with servers by limiting the number of concurrent connections.  This is configurable, but it's not meant to be easily discoverable by users.  See the network.http.max* preferences.

This is discussed more in bug 156743.  Making this limit more friendly in terms of queueing up multiple files was done in bug 263698.  Use Firefox 1.5 beta to see this.

*** This bug has been marked as a duplicate of 156743 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: Download Manager → Networking: HTTP
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.