Cyrus IMAP Inbox "1st level folders" disappear problem

VERIFIED WORKSFORME

Status

P2
major
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: huang, Assigned: jefft)

Tracking

({imap-interop})

Trunk
x86
Windows NT
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
Used 03-10-13-M15 commercial build:

Cyrus IMAP Inbox "1st level folders" disappear problem

Setup info & steps:
1) Create cyrus new profile by using today build.
2) First login without setup IMAP Advanced dialog for "Inbox."
3) All the 1st level folders of Inbox seemed to display this time.
4) But after setup the IMAP Advanced dialog for "Inbox." and login again
5) Actual Results: The 1st level folders of Inbox just disappear

Expected Results: Should display 1st level folders of Inbox completely.

Addtional Info: I did check the IMAP log, all the folders are there:
(Jeff saw this problem today, too and it's reproducible)

284[b59ca80]: buggy.mcom.com:A:SendData: 4 lsub "" "Inbox.*"
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.Drafts
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.In_3
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.In_3.in_3_1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.In_3.in_3_1.in_311
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.In_3.in_3_1.in_311.in_3111
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.Sent
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.Templates
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.Trash
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.bf1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.bf1.bf1_1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1.cyrus_f11
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1.cyrus_f11.cyrus_f111
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1.cyrus_f11.cyrus_f111.cyrus_f1111
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1.cyrus_f2
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1.cyrus_f2.cyrus_f21
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.cyrus_f1.cyrus_f2.cyrus_f21.cy_f211
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.g.h
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.in_1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.in_2
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." Inbox.in_4
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.in_f4
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.in_f4.in_f4_1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.in_f4.in_f4_1.in_f4_1_1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LSUB () "." 
Inbox.in_f4.in_f4_1.in_f4_1_1.in_f4_1_1_1
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: 4 OK Completed
284[b59ca80]: buggy.mcom.com:A:SendData: 5 list "" "INBOX"
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: * LIST () "." INBOX
284[b59ca80]: buggy.mcom.com:A:CreateNewLineFromSocket: 5 OK Completed
(Reporter)

Updated

19 years ago
QA Contact: lchiang → huang

Comment 1

19 years ago
-> jefft
Assignee: phil → jefft
(Reporter)

Comment 2

19 years ago
Raising Priority to P2, change Serverity to "blocker" since I cannot delete msgs 
to trash folder if this bug not get fixed. Beta1?
Severity: normal → blocker
Priority: P3 → P2

Comment 3

19 years ago
Karen - "blocker" means you cannot test a feature at all across the entire 
component.  With other folders, we are able to test deleting msgs.

If this is specific to the Cyrus server?  Is this a regression (ie. was this 
working before)?
(Reporter)

Comment 4

19 years ago
Yes. Should be regression. Adding pp, Change serverity from blocker to major.
Severity: blocker → major
Keywords: pp
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Reporter)

Comment 5

19 years ago
Jeff, do you think this should be fixed in beta1?
Since problem still occurring on today's beta1 commercial build.....
(Assignee)

Comment 6

19 years ago
I don't know. I don't have time to look into this yet.
(Reporter)

Comment 7

19 years ago
Adding beta 1 on the keywords. 
Let PDT team to decide this is PDT+ or PDT- for beta1.
Keywords: beta1

Comment 8

19 years ago
If I had to guess... I'd say it is too late.  If there was an incredibly simple
fix in hand... then it might have had a chance... but by the time the PDT meets
on Monday, I think the time will be gone.
Beta 1 is almost in the can now... so changes are not likely.

Comment 9

19 years ago
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]
(Reporter)

Updated

19 years ago
Keywords: relnote

Comment 10

19 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16
(Reporter)

Comment 11

19 years ago
*** Bug 36772 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

19 years ago
Based on PDT team & Phil's comments from bug#36772.
Updating the whiteboard & keywords for nsbeta2+ bug!!
Keywords: beta1, pp, relnote → nsbeta2
Whiteboard: [PDT-] → [nsbeta2+]

Comment 13

19 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 14

19 years ago
adding interop keyword so we can track our interop bugs easily for mail connect.
Whiteboard: [nsbeta2+] → [nsbeta2+],interop

Comment 15

19 years ago
correcting to keyword
Keywords: interop
Whiteboard: [nsbeta2+],interop → [nsbeta2+]
(Assignee)

Comment 16

19 years ago
Karen, can you try this again? This seems working fine for me with today's 
build.
(Reporter)

Comment 17

19 years ago
Yes. I already verified -- no problem now!!
Jeff, you can mark workforme now...since it's no problem for today's build.
(Assignee)

Comment 18

19 years ago
Cool. One more down.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 19

19 years ago
Sounds like IMAP interop beta2 is better than beta1!! 
I am wondering to know whether this is because you fix the namespace bug so fix 
this as well?? Marking as verified anyway!!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 20

19 years ago
Hmm.... it shouldn't because namespace...maybe someother UI bug fixed!!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.