reconstructing URL from MIME text breaks identification of URL boundaries

RESOLVED DUPLICATE of bug 5351

Status

--
major
RESOLVED DUPLICATE of bug 5351
13 years ago
5 years ago

People

(Reporter: mo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

when a URL crosses a line-break in an underlying email body, the viewer correctly splices it back together as a single string, but the underlining machinery which provides "click-to-open" on the URL stops at the break in the underlying text. this leaves the last piece of a URL non-underlined and if you click-to-open, only the underlined fragment is handed to the browser. the rest of the URL is ignored.

Reproducible: Always

Steps to Reproduce:
1.send yourself an email with a long URL which crosses a MIME line-length boundary
2.open the email
3.observe that only the first part of the URL is underlined
4.click-to-open
5.observe that only the underlined first part is given to the browser

Actual Results:  
only the part of the URL before the underlying line break is underlined,
and when clicked, only the first part (ie, the underlined part) is given to the browser

Expected Results:  
the entire URL should be underlined and handed to the browser.
this worked correctly in previous versions of Thunderbird.

Comment 1

13 years ago
Related to/duplicate of Core bug 5351?

Comment 2

12 years ago
That dupe is likely, but reporter mentions "MIME text breaks" -- Mike O'Dell, does this mean the message was sent quoted-printable, such that the URL appeared completely concatenated, all on one line?

Comment 3

12 years ago
here's one Seth - I guess there's an ancient bug as well.
Seth points out that mail.app is especially bad about generating these kinds of urls.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

12 years ago
I've noticed a similar problem when getting messages with
  Content-Type: text/plain; format=flowed; delsp=yes
and a broken URL (with a trailing space) which is supposed to be removed.
The URL displays correctly -- that is, unbroken -- but the linkification only applies to the first part.
QA Contact: front-end
Assignee: mscott → nobody
Per comment 0, comment 1 and comment 2, this does look like a duplicate of bug 5351 to me.
Feel free to reopen if I'm wrong with more information why.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 5351
You need to log in before you can comment on or make changes to this bug.