GUI bug in dual-monitor system.

RESOLVED DUPLICATE of bug 245418

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED DUPLICATE of bug 245418
12 years ago
12 years ago

People

(Reporter: kasper, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Version 1.6a1 (20051029)

This bug should be given lowest priority.

I use two monitors. The right one is my main monitor, and we'll call that one M1. The second extends the desktop to the right, and we'll call that one M2.
When FB windows are extended from M1 into M2, and a pop-up menu is invoked on M2 (like the one that says "Customize..." when right-clicking the Mail Toolbar), the menu appears on the right edge of M1.
However, when the window is moved to fit inside M2, pop-up menus (and tooltip windows) appears near the mouse cursor as they are supposed to do. Also, when the window is extended FROM M2 into M1, the menus and tooltips are displayed correctly.
Finally, if TB is closed while the main window is extended across both windows, the next time it is started, it will fit the window into M1 (ie. not save the correct window dimensions).

FireFox has the same behavior.

MSDN has a section for dual-monitor systems:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/gdi/monitor_53sj.asp

Reproducible: Always

Steps to Reproduce:
1.Extend the main FB window from the main monitor into the secondary monitor.
2.Invoke a pop-up menu on the secondary monitor or hover the mouse cursor for a moment over an item that has an associated tooltip.

Actual Results:  
The pop-up menu or tooltip appears on the right edge of the primary monitor.

Expected Results:  
The pop-up menu or tooltip should appear near the mouse cursor.
(Reporter)

Comment 1

12 years ago
TYPO in my own comment:
First line:
"The right one is my main monitor, and we'll call that one M1"
Should have been
"The LEFT one is my main monitor, and we'll call that one M1"

Comment 2

12 years ago
Already fixed in the latest branch - will be in Thunderbird 1.5.

*** This bug has been marked as a duplicate of 245418 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 3

12 years ago
It is said on Bug 245418 that this should be opened for Mac only. 

The problem is not solved on 1.5.0.4 and OS X 10.4.5 with dual screen.

Again: Problem might be solved on Windows, but still occurs on Mac. Please reopen.

Comment 4

12 years ago
Sorry - One week of festival has made my brain a zombie. Disregard the last message and leave closed. Bug 314279 is where it's at.
You need to log in before you can comment on or make changes to this bug.