search plugins don't install on windows from limited accounts

RESOLVED DUPLICATE of bug 123315

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 123315
12 years ago
12 years ago

People

(Reporter: sunpascal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

search plugins don't install on windows from limited accounts, since they are safed in the installation directory of firefox (to which a normal/limited user usually doesn't have write permissions). Better put the search plugins in %appdata% along with each user's extensions and personal preferences. Also, this way every user can have their own search engines on a multi user machine.

Reproducible: Always

Steps to Reproduce:
1. install any search plugin from a user (limited) account on winxp.

Actual Results:  
same

Expected Results:  
install search plugins (into user profile)
Fixed for Firefox 1.5.

*** This bug has been marked as a duplicate of 123315 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
however all users have the same search plugins. It would be better if it was like the extensions.
I'm not sure what you mean. Search plugins are now stored in the profile, so different users can have different search plugins. Better search management is scheduled for Firefox 2.0.
You need to log in before you can comment on or make changes to this bug.