Thunderbird is already running error when upgrading from 1.0.7 to 1.5b2

RESOLVED DUPLICATE of bug 313360

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 313360
12 years ago
12 years ago

People

(Reporter: Rohnny, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686; en) Opera 8.5
Build Identifier: http://www.mozilla.org/products/thunderbird/releases/1.5beta2.html

Aften upgrading from 1.0.7 to 1.5b2, I get this error when I try to start thunderbird:

"Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Thunderbird process, or restart your system."

I use a shared profile between linux and windows, and I only get the problem
when using absolute path in .thunderbird/profiles.ini. Like this:

[Profile0] 
Name=ThbProfile 
IsRelative=0 
Path=/windows/D/shared/thbprofile

No thunderbird process is running of course, when I start thunderbird.


Reproducible: Always

Steps to Reproduce:
1. Install tb 1.5b2 on linux and start it.
2. copy the created profile .thunderbird/fdsf.default to e.g /local/thbprofile.
3. Edit .thunderbird/profile.ini to use absolute path and point to thbprofile.
4. Start tb.


Actual Results:  
Error message:
"Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Thunderbird process, or restart your system."


Expected Results:  
A feature rich tb 1.5b2 should start up perfectly. :)

Comment 1

12 years ago
File permission problems? Also, if there is a "parent.lock" or "lock" file in your profile, delete it.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> File permission problems? Also, if there is a "parent.lock" or "lock" file in
> your profile, delete it.

Thanks for your reply. Mmmm..I had a .parentlock file in my profile directory, but it didnt help to delete it. I'll check that with file permission problems. But how come it works with thunderbird 1.0.7 using exactly the same settings? I have my shared profile on a fat32 partition. I'll try and copy it to another place and still use absolute path, and report back later today.
(Reporter)

Comment 3

12 years ago
Ok. Tried now to copy it to another place and still use absolute path and it works. Still, I have write/read permissions to the fat32 partition, so I dont understand. And using exactly the same setup, but thunderbird 1.0.7 works fine. 

Comment 4

12 years ago
So it's only a problem if the profile is on a fat partition? Are you sure the fat partition is mounted with read and write privileges? 

Comment 5

12 years ago
Ahh, there's a dupe. Sounds like it will be fixed for 1.5 if there is an rc2. 

*** This bug has been marked as a duplicate of 313360 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> Ahh, there's a dupe. Sounds like it will be fixed for 1.5 if there is an rc2. 
> 
> *** This bug has been marked as a duplicate of 313360 ***

Ok, thanks. I think it was strange that it happened only on the fat partion, but I understand now. :-)
You need to log in before you can comment on or make changes to this bug.