Closed Bug 314533 Opened 16 years ago Closed 16 years ago

Plug-in instance destroyed by display="none"

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 90268

People

(Reporter: vlad.alexander, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Many users of our plug-in (XStandard) are trying to hide/show the plug-in via JavaScript. When the following JavaScript is called:

document.getElementById('panel').style.display = 'none'

The current instance of the plug-in is destroyed. Then a new instance of the plug-in is created when the following JavaScript is called:

document.getElementById('panel').style.display = ''

In the process, they the text typed into the plug-in is lost.

Note, this does not happen to other form controls like <input> or <textarea>.

Here is a test page:
http://xstandard.com/misc/mozilla/hide.htm

FYI, IE does not destroy the plug-in instance.


Reproducible: Always

Steps to Reproduce:
1. Load a page with a plug-in.
2. Apply the following JavaScript to a parent element of the plug-in:
document.getElementById('panel').style.display = 'none'
3. Apply the following JavaScript to a parent element of the plug-in:
document.getElementById('panel').style.display = ''

Actual Results:  
The current instance of that plug-in will be destroyed and a new instance will be created.

Expected Results:  
The current instance of the plug-in show not be destroyed.

Here is a test case:
http://xstandard.com/misc/mozilla/hide.htm

*** This bug has been marked as a duplicate of 90268 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.