reporter should have a checkbox for "this used to work"

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
13 years ago
a month ago

People

(Reporter: dbaron, Assigned: raccettura)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It would be useful if reporter had a checkbox so the reporter of the problem could say something used to work in Mozilla (same or older version).  This would be particularly useful for catching regressions caused by changes to Mozilla.

This doesn't even need to distinguish between used to work in this version (guaranteed to be a website change) or used to work in an older version (could be either a site change or a Mozilla change).  We could do the necessary statistical analysis to determine whether it was a change in the site or a change in our code that caused the problem.  The simple way to do that is to do a scatterplot of the reports for a site with the build date vs. the report date and see if there's a clear horizontal line or a clear vertical line.  But it would be even better if the reporter server system automated this so that reports probably caused by layout regressions could be flagged.
(Assignee)

Comment 1

13 years ago
I agree this is a potential candidate to be added.

A few notes:
1.  User Error can skew things a bit.  Just take a look at how some reports are misfiled (mozilla.org has a bunch of reports for other domains, because people were too lazy, or didn't know to report when *at* the site).  

2.  You may already be able to do this.  Simply by taking the "top 25" from Firefox/[old version] and comparing to Firefox/[present version] (you may need to play with the URL's for now (&report_product=Firefox%2F1.0+)).  The differences will likely be from either a regression, or a new website that became popular.  Of course this doesn't have as much accuracy either.

In any regard, it's well worth considering.

Screenshots should also help with regression tracking.
(Assignee)

Comment 2

13 years ago
Lets evaluate this for the next release.
Blocks: 315750
Reporter isn't a maintained project. Closing!
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → WONTFIX

Updated

a month ago
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.