Closed Bug 314558 Opened 14 years ago Closed 13 years ago

Flash plugin crash when rapidly moving between tabs

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

()

Details

(Keywords: crash)

Attachments

(2 files)

Seeing using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5. I can reproduce this consistently on my test machine.

STR:

1. Set espn.go.com and sportsillustrated.cnn.com as your home page.
2. While these pages are loading, add a new set of tabs and then click in them rapidly.
3. Firefox crashes

During this testing period, haven't been able to get talkback to launch but captured the Apple report, which I will attach.

Testing using Mac OS X 10.4.2, Shockwave Flash 8.0 r12
Attached file Apple Crash Report
Forgot to mention that I have Adblock extension installed.

(In reply to comment #0)
> Seeing using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8)
> Gecko/20051025 Firefox/1.5. I can reproduce this consistently on my test
> machine.
> 
> STR:
> 
> 1. Set espn.go.com and sportsillustrated.cnn.com as your home page.
> 2. While these pages are loading, add a new set of tabs and then click in them
> rapidly.
> 3. Firefox crashes
> 
> During this testing period, haven't been able to get talkback to launch but
> captured the Apple report, which I will attach.
> 
> Testing using Mac OS X 10.4.2, Shockwave Flash 8.0 r12
> 

Severity: normal → critical
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 1.5 Branch → 1.8 Branch
The first crash is in the Flash plugin, when we're sending it a null event (it's in the timer fire).

The second crash looks Java-related.
Please retest with Flash Player 8r22. Any version of Flash Player 8 prior to 8r22 is a beta version and could be causing these crashes. Thanks.
still happens?
I haven't seen this problem post Firefox 2, and I am not able to reproduce it using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061213 BonEcho/2.0.0.1. Resolving as WFM.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Target Milestone: --- → 2005
Version: 1.8 Branch → 8.x
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2005 → ---
Version: 8.x → unspecified
You need to log in before you can comment on or make changes to this bug.