The cursor moves back one position while typing in any textbox and in any webpage when connected to VPN.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: viralcse, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I get connected to a clientless VPN using Firefox. 
After getting connected to the VPN if i open any browser window and
type in any of the text boxes after a random number of characters the cursor shifts back by one character and therefore the words being typed get messed up. For example if I am typing " This is a test message " it would be shown something like this " Tish is a tste messaeg " - In the above sentence the cursor went back after typing "Th" - "T|h" - "Tish". 
Similarly the cursor shifted one position back at the 'e' in the word 'test' and at 'g' in the word 'message'. 
If someone is working with VPN please could you fix this and help me from getting annoyed. 
Thanks.

Reproducible: Always

Steps to Reproduce:
1.connect to clientless VPN using firefox
2.open browser tabs.
3.type into any textbox on any webpage

Actual Results:  
While typing the cursor will shift its position one step back and if you dont see while you are typing all the words get messed up even if you try to delete and type the occurence of the cursor shifting its position increases. But if i type the information in Notepad and copy/paste it in to the textbox or textarea it lets me do it.

Expected Results:  
It should not move the cursor because it is completely annoying. 

I dont have any clue why it is doing this since i dont know how VPN works though i use it. It could be something serious too. Thanks.

Comment 1

13 years ago
*** Bug 331212 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
observed the same thing while using some web site (password field). Unfortunately I don't remember the site address and havn't reproduced that behaviour.

Observation: The problem seems to be related to the typing speed. If I type in the text very slow, the problem doesn't show up. Type fast and you get an automatic typo.

Seen in Firefox 1.5.0.4

Comment 3

12 years ago
viralcse, 
Frank, 
do you see this in FF 2?

Comment 4

12 years ago
Sorry, can't say - due to workload I've not yet switched over to FF2. I'm at FF 1.5.0.9 by now and I have not seen the problem for some time, but that's no guarantee that it has vanished in the meantime ... 

Comment 5

11 years ago
Hi,

I've seen this happening in FF 2.0.0.3 and 2.0.0.4 as well.

Comment 6

11 years ago
what VPN(s) are we talking about here?
always happens, and frequently?

I use windows VPN on all the time and have no problem.
Severity: normal → minor

Comment 7

10 years ago
I observed this in the Linux version, without VPN. However, I must admit in more recent versions of FF I've not seen this anymore. So from what I can tell, this appears to be fixed.

Comment 8

10 years ago
haven't heard from reporter, so let's go with that. Thanks Louis.
=> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 9

10 years ago
i am experiencing the same with ff3.0.1 on xp as long as certain java applet/javascript runs (java: Build 1.5.0_12-b04).
open in 2nd tab: http://lsd.onvista.de/
select an option in the first select field, script/applet will kick in
now r to fill in some inputfied text area rol yt
cose the tab wth onvsatiil
now everything is fine again

always reproducible (i'm using an on screen keyboard)

Comment 10

10 years ago
forgot to say: no vpn involved
You need to log in before you can comment on or make changes to this bug.