Javascript defined M14 as non-netscape!

VERIFIED DUPLICATE of bug 30602

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED DUPLICATE of bug 30602
18 years ago
16 years ago

People

(Reporter: Tsang Ho-man, Amuro, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US) Mozilla/m13
BuildID:    20000022820

Javascript defined M14 as non-netscape browser!
There is no problem when I'm using M13

(P.S.:My XOOM counter also defined my OS is Win3.1 but my OS is Win98 when I am
using M14. This does not appear when I'm using M13 and Netscape 4.7)


Reproducible: Always
Steps to Reproduce:
1. Type URL http://wahyancats.wegjump.com
2. Javascript pop-up automaically
3.


Actual Results:  My Javascript defined M14 as non-netscape

Expected Results:  Make it define as Netscape, just like M13

Comment 1

18 years ago
Mozilla is not Netscape. Netscape (the company) will make a Netscape (browser) 
out of Mozilla but Mozilla itself is Mozilla and not Netscape.

The problem with you JavaScript code is that it depend on the value of 
navigator.appName to detect different browsers. I'm tempted to mark this bug 
INVALID but I leave that to someone who can see if there is any other problem 
here.
DUP 30602. FIXED. In all dailies, milestones, and product builds of both Mozilla 
and Netscape branded browsers, navigator.appname will return "Netscape" for 
backward compatibility.

*** This bug has been marked as a duplicate of 30602 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.