If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Extension manager messages in Error Console

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

({fixed1.8.1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
In bug 264537, extension manager update messages sent to the command line were suppressed. The javascript console should have gotten the same treatment, patch coming up. 

This affects Thunderbird too, because this is toolkit code.
(Reporter)

Comment 1

12 years ago
Created attachment 201512 [details] [diff] [review]
Extend the if to include the javascript console
Attachment #201512 - Flags: review?(robert.bugzilla)

Comment 2

12 years ago
I'm worried about this: we do want error/warning messages to appear in the JS console by default... the only messages we should be suppressing by default are informational/success messages.
Comment on attachment 201512 [details] [diff] [review]
Extend the if to include the javascript console

I agree with Benjamin... I think that the current logging needs some cleaning up but that is going to take quite a bit more work to do properly. This would be a good bug to do this in.
Attachment #201512 - Flags: review?(robert.bugzilla) → review-
(Reporter)

Updated

12 years ago
Assignee: nrthomas → nobody

Updated

12 years ago
Summary: Extension manager messages in javascript console → Extension manager messages in Error Console
*** Bug 348405 has been marked as a duplicate of this bug. ***
So... why, as a user (say a web developer), would I care about _any_ of these messages?  All they do is clutter up the console and get in the way of me seeing real issues in code that I'm actually trying to fix.

At the very least, shouldn't these follow the chrome error prefs?  But better yet, if logging is not enabled for extension stuff, don't log it!
Comment on attachment 201512 [details] [diff] [review]
Extend the if to include the javascript console

I think we should take this and work out better logging as time permits.

Benjamin, are you ok with this?

Comment 7

11 years ago
Can't we just control it with a pref? That's what other JS code that uses logging does.
That is what this patch does... it makes it so we don't dump unless the extensions.logging pref is true.

What I would like is to always log important errors that don't throw and will hopefully have time to revamp this to do so for 3.0
Comment on attachment 201512 [details] [diff] [review]
Extend the if to include the javascript console

Taking this patch from Nick Thomas (cf) so we can hopefully get it for Firefox 2.0. I seldom benefit from these logs currently and believe that extension authors are the main audience that benefits from them... they can just flip the pref.
Attachment #201512 - Flags: review- → review+
Comment on attachment 201512 [details] [diff] [review]
Extend the if to include the javascript console

Simple patch to reduce noise in the Error Console.
Attachment #201512 - Flags: approval1.8.1?
Checked in to trunk
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Comment on attachment 201512 [details] [diff] [review]
Extend the if to include the javascript console

a=beltzner on behalf of drivers for the mozilla_1_8_branch
Attachment #201512 - Flags: approval1.8.1? → approval1.8.1+
Checked in to MOZILLA_1_8_BRANCH
Keywords: fixed1.8.1
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.