Program response time is very slow

VERIFIED DUPLICATE of bug 306834

Status

VERIFIED DUPLICATE of bug 306834
13 years ago
11 years ago

People

(Reporter: noah, Assigned: shaver)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

The response time in Sunbird is slow on all fronts from opening windows to typing text.

Reproducible: Always

Steps to Reproduce:
1. Open Sunbird
2. Type something somewhere

Actual Results:  
There was a noticable delay between my typing/opening of windows and the appearance of that text/window

Expected Results:  
I would expect that the program response times would be in line with other programs.

Comment 1

13 years ago
I can't reproduce this.
Are you sure you don't have a lot of stuff started that uses all your resources? Have a look in the task manager.

What version of sunbird are you using?

Comment 2

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8)
> Gecko/20051025 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8)
> Gecko/20051025 Firefox/1.5
> 
> The response time in Sunbird is slow on all fronts from opening windows to
> typing text.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Open Sunbird
> 2. Type something somewhere
> 
> Actual Results:  
> There was a noticable delay between my typing/opening of windows and the
> appearance of that text/window
> 
> Expected Results:  
> I would expect that the program response times would be in line with other
> programs.
> 

I can reproduce this using the 20051101 build.  My CPU utilization is %50 (I am hyperthreaded) I used Filemon from Winternals an was able to see the following, which continues on and on... Looks like it can't find storage.sdb-journal and gets stuck in a loop.

1:50:46 PM	sunbird.exe:3912	QUERY INFORMATION	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb-journal	NOT FOUND	Attributes: Error	
1:50:46 PM	sunbird.exe:3912	QUERY INFORMATION	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Length: 15360	
1:50:46 PM	sunbird.exe:3912	READ	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 0 Length: 1024	
1:50:46 PM	sunbird.exe:3912	READ	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 4096 Length: 1024	
1:50:46 PM	sunbird.exe:3912	READ	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 12288 Length: 1024	
1:50:46 PM	sunbird.exe:3912	READ	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 13312 Length: 1024	
1:50:46 PM	sunbird.exe:3912	READ	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 14336 Length: 1024	
1:50:46 PM	sunbird.exe:3912	UNLOCK	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 1073741826 Length: 510	
1:50:46 PM	sunbird.exe:3912	LOCK	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Excl: Yes Offset: 1073741824 Length: 1	
1:50:46 PM	sunbird.exe:3912	LOCK	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Excl: No Offset: 1073741826 Length: 510	
1:50:46 PM	sunbird.exe:3912	UNLOCK	C:\Documents and Settings\abc\Application Data\Mozilla\Sunbird\Profiles\t5is1vv4.Default User\storage.sdb	SUCCESS	Offset: 1073741824 Length: 1	
Does the cpu usage happen in all the views?

Comment 4

13 years ago
(In reply to comment #3)
> Does the cpu usage happen in all the views?
> 

Yes it does.
Can you try to see if getItems in the storage provider is the thing that get called all the time?
You can try to find out by adding a dump() in calStorageCalendar.js in the components dir. You need to set the pref "browser.dom.window.dump.enabled" to true, and start with sunbird -console.

Comment 6

13 years ago
This is the only output that I get.

Starting calendar alarm service
error creating table cal_calendars -- probably already exists
error creating table cal_calendars_prefs -- probably already exists
*** Calendar schema version is: 4
observer added
Guessing system timezone:
TZoffset1: -0400
TZoffset2: -0500
TZname1: Eastern Daylight Time
TZname2: Eastern Standard Time
gDefaultTimezone: /mozilla.org/20050126_1/America/New_York
You don't have mail installed
Fetching events from Sun Oct 30 2005 00:00:00 GMT-0400 (Eastern Daylight Time) t
o Sun Dec 11 2005 00:00:00 GMT-0500 (Eastern Standard Time)
onOperationComplete
(Reporter)

Comment 7

13 years ago
(In reply to comment #1)
> I can't reproduce this.
> Are you sure you don't have a lot of stuff started that uses all your
> resources? Have a look in the task manager.
> 
> What version of sunbird are you using?
> 

There doesn't seem to be a problem today. I'm using the 20051030 build. At the time that the problem occured other programs like Firefox and Thunderbird worked fine and every time I reopened Sunbird the problem reoccured. Perhaps the whole thing my be related to Sunbird crashing while I was filing the bug report. Does Sunbird have TalkBack? I only got the typical Windows closing the program crash message.

Comment 8

13 years ago
(In reply to comment #7)
> There doesn't seem to be a problem today. I'm using the 20051030 build. At the
> time that the problem occured other programs like Firefox and Thunderbird
> worked fine and every time I reopened Sunbird the problem reoccured. Perhaps
> the whole thing my be related to Sunbird crashing while I was filing the bug
> report. 

There are some testing about this issue going on in #calendar on irc.mozilla.org. It looks like it's the unifinder doing something it shouldn't (I'm not sure what).

> Does Sunbird have TalkBack? I only got the typical Windows closing the
> program crash message.

Sunbird does not have TalkBack, at least not  yet.

Comment 9

13 years ago
I also get 100% CPU usage when idle, but Filemon doesn't see any activity on Sunbird's part.

However, I did notice that if none of the calendars I have are selected for display, Sunbird goes back to 0% CPU. This suggests it's getting into a loop trying to display the events...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

13 years ago
Resolving as a duplicate 0f Bug 306834.

*** This bug has been marked as a duplicate of 306834 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.