Drag 'n Drop of a tab to the right/left should always place it at right/left of the tab hovering over.

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: Daniel Höpfl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Playing with the new drag 'n drop of tabs I was confused for a moment:

I dragged Tab #2 to the place of Tab #3 but nothing changed. Dragging Tab #2 onto isself showed a "can't drop" cursor but dragging onto Tab #3 did not.

The reason for this is clear: Firefox has invisibly split the tab into a "drop to the left" and "drop to the right" areas.

My idea for a solution would be that dragging to the right/left always inserts behind/before the existing Tabs.

Currently the user has to move the mouse to move the arrow to select the place where to drop the tab. With my suggestion the user could select the target with the mouse.

The little blue arrow could be removed, too, if there was live feedback (with a cool Apple-like sliding effect?) during the drag operation.


Reproducible: Always
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Works properly with the new directly-draggable tabs
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.