Selection of alternative Style not preserved when changing or refreshing Webpage

RESOLVED DUPLICATE of bug 216537

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 216537
13 years ago
13 years ago

People

(Reporter: movgp0, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051025 Firefox/1.5

Considering a website with alternative Stylesheets:
 <link href="Blue.css" rel="stylesheet" title="Blue" type="text/css" />
 <link href="Red.css" rel="stylesheet" title="Red" type="text/css" />
 <link ... />
Now first Style (ie. Blue) becomes Default. If the user changes this (View/Website-Style/...) the Website appears with the other Style (ie. Red).

But if the user is now refreshing the website (or navigating of any kind) this behavior is thrown and the first Style (Blue) is taken again instead of keeping the user-preference.

Reproducible: Always

Steps to Reproduce:
1. Create a Website with alternative Stylesheets
2. Change the style (View/Website-Style/...)
3. Refresh the page or navigate away and back

Actual Results:  
the style is changed to default-setting

Expected Results:  
(a) The settings should preserved for the whole domain as long a style (with fitting title property - not css-file!) is available.
(b) The settings should be persistent stored within a cookie if possible.
(c) If the style becomes unavailable, firefox should choose the default-style again (rather than choosing none)
(d) make it possible to change the style even for parts of the domain - acording to a ruleset. Ie. there could be a ruleset like "*.example.org" uses "Blue", "sun.example.org" uses "Red", and "example.org/moon" uses "Green".

A workaround might be to handling this by changing the style by a property at the Server. But this is much work for the developers, because they have to distingush different user-settings (when logged on); serving with cookies (for visitors); pagestate information (reading the choosen style from the http-request); and so on...

Comment 1

13 years ago
Duplicate of bug 216537?

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 216537 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.