Updating from latest stable to 1.5 RC erases custom search engines / overwrites custom search engines with defaults

RESOLVED DUPLICATE of bug 311626

Status

()

--
major
RESOLVED DUPLICATE of bug 311626
13 years ago
13 years ago

People

(Reporter: cheers, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

I just updated the latest stable to 1.5RC using the standard Windows installer. I did neither uninstall the old installation, touch the profile directory nor change any paths.

After the installation process completed, Firefox did a great job of importing all the settings from my profile, except the list of search engines. 

It's really no biggie but it would be nice to have Firefox import custom search engines as well if this really turns out to be bug and not just a problem at my end.

Reproducible: Always

Steps to Reproduce:
I have been able to reproduce this on another computer. The second machine's installation is based on the same roll-out image as the first though so it's virtually identical to the first computer. 

Not exactly an ideal setup to test reproducibility but at the moment it's all I have access to. Sorry. :(

I apologize if this turns out to be a problem on my end but I felt I should report it, especially since it's a RC release.
Actual Results:  
After manually updating all my themes and extensions, all the graphical glitches were gone. However, the search engine pull down menu only shows the default 6 engines and not the 12 or so I had previously installed.

Expected Results:  
Firefox should import and display custom search engines as well.

Thanks for your hard work. It is greatly appreciated. :-)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051102 Firefox/1.5 ID:2005110218

WFM. 
See Bug 123315.

*** This bug has been marked as a duplicate of 311626 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.