AutoUpdate fails and then repeats forever

RESOLVED DUPLICATE of bug 314684

Status

()

Toolkit
Application Update
--
major
RESOLVED DUPLICATE of bug 314684
13 years ago
10 years ago

People

(Reporter: Derick Eisenhardt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I was using Firefox 1.4.1 (1.5 Beta 2), and today the autoupdate feature popped up and informed me of a newer version (1.5 RC1) being available. It told me it had already downloaded it, and I would simply need to reboot. I clicked later, as I was currently reading a few pages I had up. After I was done, I closed FF out, and then restarted it manually. The software update progress bar popped up and went through. Once FF was up again, I noticed it still said "Beta 2" at the top. So I went to check the version in "about", and sure enough, it still listed itself as the same version I already had. Then I noticed there was a message in the Help menu saying "Downloading Firefox 1.5".... I clicked it and it was downloading a 6MB file, and once it was complete it brought up the same dialogue as before. This time I clicked install and restart now. When I started FF up again it did the software update progress bar again, but it was still the Beta 2 version. It once again downloaded and reset, and over and over and over again... I'm running this on WinXP SP2, with a full privaleges account by the way. I'll have to try it under Linux sometime to see if it's OS specific ;)

I hope this is not a dupe, I couldn't find any other bugs like it... Sorry if it is. Keep up the great work guys! :D

Reproducible: Always

Steps to Reproduce:
1. Use FF 1.4.1 (Beta 2)
2. Do not manually update, but wait for it to automatically update
3. Attempt to install/restart FF
4. Nothing changes, and it attempts to update again and again and again :(
Bad luck, because this is a dupe.

*** This bug has been marked as a duplicate of 314684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.