Firefox crashes or hangs (100% cpu) on sending POST data

RESOLVED DUPLICATE of bug 314257

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 314257
12 years ago
12 years ago

People

(Reporter: Noa Groveman, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051102 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051102 Firefox/1.5

This happens several times a day to me:

I'll be sending POST data via Invision Power Board, and right after hitting the send button Firefox will either crash or hang at 100% CPU usage - this has been going on since 1.0 as far as I can remember - it's also a problem on Windows XP, though I am currently running Windows 2000 - I'll attach the details.txt file generated by talkback, as I'm not sure what the ID is

Reproducible: Sometimes

Steps to Reproduce:
Happens maybe once every 500 times I send POST data, hard to reproduce, but guaranteed to happen at least a few times daily.
(Reporter)

Comment 1

12 years ago
Created attachment 201674 [details]
talkback info from crash

Comment 2

12 years ago
Could you install Firefox with talkback and post the talkback ID here? It'll be much more useful than MS's one without symbols. http://kb.mozillazine.org/Talkback
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Could you install Firefox with talkback and post the talkback ID here? It'll be
> much more useful than MS's one without symbols.
> http://kb.mozillazine.org/Talkback
> 

Ah, the talkback id is 11377645, I wasn't looking in the right place.  Looks like talkback hasn't processed it yet, however.

Comment 4

12 years ago
Incident ID: 11377645
Stack Signature	nsEventStateManager::GetPrevDocShell bbfba8ec
Product ID	Firefox15
Build ID	2005110203
Trigger Time	2005-11-02 13:29:10.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	firefox.exe + (002a33ce)
URL visited	
User Comments	submitting POST data
Since Last Crash	26197 sec
Total Uptime	26197 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventStateManager.cpp, line 5369
Stack Trace 	
nsEventStateManager::GetPrevDocShell  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventStateManager.cpp, line 5369]
nsEventStateManager::ShiftFocusByDoc  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventStateManager.cpp, line 5419]
nsEventStateManager::PostHandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/content/events/src/nsEventStateManager.cpp, line 2173]
PresShell::HandleEventInternal  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6439]
PresShell::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6203]
nsViewManager::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp, line 2514]
nsViewManager::DispatchEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 1252]
nsWindow::DispatchKeyEvent  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 3448]
nsWindow::OnKeyDown  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 3586]
nsWindow::ProcessMessage  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 4492]
nsWindow::WindowProc  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 1434]
USER32.dll + 0x1ef0 (0x77e11ef0)
USER32.dll + 0x204c (0x77e1204c)
USER32.dll + 0x21af (0x77e121af)
nsAppStartup::Run  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 61]
KERNEL32.DLL + 0x2893d (0x7c59893d)


*** This bug has been marked as a duplicate of 314257 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: crash
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

12 years ago
Sorry to continue with this, but am I correct in assuming the crash was caused by bug 162283?
(In reply to comment #5)
> Sorry to continue with this, but am I correct in assuming the crash was caused
> by bug 162283?
> 

I guess you are, since this bug has been marked as a duplicate of my bug 314257 which was already marked as a duplicate of bug 162283
You need to log in before you can comment on or make changes to this bug.