IFRAME URLs containing ? behave erratically

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Iain Brown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

If I have the url "src="http://www.webl.com/rcm.amazon.com/e/cm?t" in an IFRAME tag, FireFox does not attempt to load the frame. If I change the final t to X ("src="http://www.webl.com/rcm.amazon.com/e/cm?X") FireFox attempts to load the frame. (There is no page there, just a 404 error.) This is condensed from a real-world problem with the url pointing to amazon, hence the strange string. If I remove the ? (or the rcm.amazon.com) I can't reproduce the failure.

Reproducible: Always

Steps to Reproduce:
1. Create a local HTML file with the following contents:
<html>
<head>
</head>

<body>
<iframe frameborder="1" src="http://www.webl.com/rcm.amazon.com/e/cm?t"
></iframe>
</body></html>

2. Point browser to file, observe blank white box with no error text

3. Change the final ?t in the url to ?X

4. Point browser to file, observe 404 error

Comment 1

12 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051102 Firefox/1.5

Comment 2

12 years ago
WFM, too.  If you navigate to the first URL normally, do you get a 404, or a blank page?  Try clearing your cache, maybe?

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051102 Firefox/1.5 ID:2005110204
(Reporter)

Comment 3

12 years ago
Apologies. Yes, I did all that - what I didn't do was disable adblock. I thought I'd done that earlier. WFM too now. Could you close / kill / update this bug as appropriate?

Comment 4

12 years ago
Resolving invalid per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.