blank pages if setting nglayout.initialpaint.delay to 0 (zero)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Andreas Morawietz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051101 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051101 Firefox/1.5

If nglayout.initialpaint.delay is set to 0, firefox doesn't display some pages - it only shows a blank page and "done" in the statusbar.

This happens very often if I have connection problems, timeouts or anyting else like this.

You should prevent, that users can choose 0 as a setting for nglayout.initialpaint.delay

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
Perhaps, if firefox gets no data from the server, it thinks that the page is completely loaden. 

If nglayout.initialpaint.delay is set to 0, it directly starts to render that page, but if there is no data to render available at this moment, perhaps, firefox stops to render because it thinks, it is complete?
(Reporter)

Comment 2

12 years ago
works now without any trouble
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.