Clicking on a sponsored link in gmail opens an unclosable tab

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: James Cook, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.11 (KHTML, like Gecko) Safari/416.12
Build Identifier: 

I've got Firefox set to open all new windows in tabs.  When I click on a sponsored link in GMail, a new tab opens but fails to load anything.  It also won't allow me to close the tab or quit the program normally.  I'm forced to open a terminal window and do a kill on the process.  This is in 1.5rc1.

Reproducible: Always

Steps to Reproduce:
1. Open gmail and select a message.
2. Click on one of the sponsored links.
Actual Results:  
A non-responsive tab opens.

Expected Results:  
A usable tab should open.

I've not yet upgraded Firefox on my windows machine, I'll give that a go and see if it's a mac-specific problem.
(Reporter)

Comment 1

13 years ago
Just tested on Windows XP and it worked properly.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051103 Firefox/1.5 ID:2005110310

WFM

(Reporter)

Comment 3

13 years ago
Just retested with 1.5rc3 - It's still broken on the OSX.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Windows continues to work correctly.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Version: unspecified → 1.5 Branch
(Reporter)

Comment 4

13 years ago
Some additional information:

If I uncheck "Force links that open new windows to open in:", and I click on a Sponsored Link, a new window opens up and it's broken in a similar fashion to when it opens up in a tab.  However, the window is closable and it doesn't prevent quitting out of Firefox.

I happened to check the Javascript console, and the following error was present:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFormFillController.detachFromBrowser]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml :: detachFormFill :: line 385"  data: no]

Don't know if it's related, but I never see that message on Windows.
Is it possible that an extension is interfering?
This is likely failing because this.docShell is null at http://lxr.mozilla.org/seamonkey/source/toolkit/content/widgets/browser.xml#393
(Reporter)

Comment 6

13 years ago
Good catch!  It turns out that Adblock was the culprit.  Many thanks for pointing that out.  =)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.