Strange Values on boxObject.screenX / screenY

RESOLVED DUPLICATE of bug 271891

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 271891
13 years ago
13 years ago

People

(Reporter: Alexandre Rodrigues, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.7.12) Gecko/20050919 Firefox/1.0.7


On commonDialog.js I've added the code:

var x = dButton.boxObject.screenX; 
var y = dButton.boxObject.screenY;

and used the x and y values but the dButton.boxObject.screenX and .screenY is returning too low values (and the dialog is centered). I've tried to see the values of the default button on a dialog with the DOM Inspector and I've got x = 477 and Y = 389.

I think it's very strange, I think it's some kind of bug and I thought it's better to report. I'm using Windows XP and I've noticed this when I was developing a new Firefox extension.

Thanks



Reproducible: Always

Actual Results:  
The actual results are X = 24 and Y = 99

Expected Results:  
The expected results are X = 477 and Y = 389

Comment 1

13 years ago
This should be fixed in FF 1.5 (you download the RC1 and test if you want).

*** This bug has been marked as a duplicate of 271891 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.