switch addons.mozilla.org downloads to releases.mozilla.org

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
13 years ago
3 years ago

People

(Reporter: myk, Assigned: justdave)

Tracking

Details

(Reporter)

Description

13 years ago
Extensions make up a large portion of ftp.mozilla.org downloads.  We have a new releases.mozilla.org download site for popular downloads which contains not only releases of our primary products but also extensions.  addons should start directing users to the new site.
I've updated existing entries in the database, however this is going to require code changes to get the correct URLs in there on an ongoing basis.
Assignee: justdave → morgamic
Component: Server Operations → Developers
Product: mozilla.org → Update
Version: other → 1.0

Comment 2

13 years ago
It should only need to be changed in the config file.
http://lxr.mozilla.org/webtools/source/update/core/config.php#58

Not 100% sure on that anymore though.
Yep, it is.  Done.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

13 years ago
Thanks!
Status: RESOLVED → VERIFIED
I backed this out...

releases is cnamed to ftp at the moment, but most of the ftp mirrors don't have releases set up as a vhost, so it's still broken on that domain.

This'll have to wait until the mirrors get synced up right.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
*** Bug 315026 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

13 years ago
releases is once again its own roundrobin, and only servers that can handle the releases.mozilla.org domain name are in the roundrobin.  It's ready for addons to point to it again.
(Reporter)

Comment 8

13 years ago
According to Mike, Dave should do this.
Assignee: morgamic → justdave
Status: REOPENED → NEW
ok, this is done again.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

13 years ago
Sure is; thanks Dave!
Status: RESOLVED → VERIFIED

Comment 11

13 years ago
*** Bug 315002 has been marked as a duplicate of this bug. ***
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.