Crash on top 100 site with popup-window

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: Bernd Mielke, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I just started hoffmanns browser buster, when mozilla build on 2000-03-11 
crashed during opening a popup-window. No asserts a straight crash.
(Reporter)

Comment 1

19 years ago
Sorry for the span here comes the stack trace, but the whole stuff may be also
related to the new introduced SSL stuff since hte popup-window is a login window.

KERNEL32! bff768a0()
nsWindow::Create(nsWindow * const 0x03a3b0b4, nsIWidget * 0x00000000, const
nsRect & {...}, nsEventStatus (nsGUIEvent *)* 0x02954e40 HandleEvent(nsGUIEvent
*), nsIDeviceContext * 0x039e0770, nsIAppShell * 0x00000000, nsIToolkit *
0x00000000, nsWidgetInitData * 0x00000000) line 891
nsView::CreateWidget(nsView * const 0x03a3b1e0, const nsID & {...},
nsWidgetInitData * 0x00000000, void * 0x00000000, int 1) line 1269
DocumentViewerImpl::MakeWindow(nsIWidget * 0x0398fb04, const nsRect & {...})
line 904 + 47 bytes
DocumentViewerImpl::Init(DocumentViewerImpl * const 0x03a21a10, nsIWidget *
0x0398fb04, nsIDeviceContext * 0x039e0770, const nsRect & {...}) line 467 + 16 bytes
nsDocShell::SetupNewViewer(nsDocShell * const 0x0398fe30, nsIContentViewer *
0x03a21a10) line 2060 + 60 bytes
nsWebShell::SetupNewViewer(nsWebShell * const 0x0398fe30, nsIContentViewer *
0x03a21a10) line 763 + 13 bytes
nsDocShell::CreateContentViewer(nsDocShell * const 0x0398fe30, const char *
0x0095fa08, int 0, nsIChannel * 0x03a43bc0, nsIStreamListener * * 0x0095fa48)
line 1930 + 24 bytes
nsWebShell::DoContent(nsWebShell * const 0x0398ff2c, const char * 0x0095fa08,
int 0, const char * 0x10084578 gCommonEmptyBuffer, nsIChannel * 0x03a43bc0,
nsIStreamListener * * 0x0095fa48, int * 0x0095f9ec) line 1404 + 38 bytes
nsDocumentOpenInfo::DispatchContent(nsIChannel * 0x03a43bc0, nsISupports *
0x00000000) line 392 + 109 bytes
nsDocumentOpenInfo::OnStartRequest(nsDocumentOpenInfo * const 0x03a43b20,
nsIChannel * 0x03a43bc0, nsISupports * 0x00000000) line 253 + 16 bytes
nsInputStreamChannel::OnStartRequest(nsInputStreamChannel * const 0x03a43bc4,
nsIChannel * 0x03a43a70, nsISupports * 0x00000000) line 350
nsOnStartRequestEvent::HandleEvent(nsOnStartRequestEvent * const 0x03a43120)
line 203
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x03a44cb0) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x03a44cb0) line 563 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0385f0f0) line 508 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00000c80, unsigned int 51342, unsigned int 0,
long 59109616) line 1018 + 9 bytes
KERNEL32! bff7363b()
KERNEL32! bff94407()
00958b7e()

(Reporter)

Comment 2

19 years ago
The same happens at http://www.developer.com, where definetely no SSL is 
involved.

Comment 3

19 years ago
DOM0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: rginda → desale
I'm unable to reproduce this, I tested both URL's mentioned here and both seem
to work, loading http://www.iwon.com on windows in a debug build I do hit a few
asserts but no crashes, on linux I don't see any problems...

Kevin, from the stacktrace here and from the asserts I saw I think this might
be a widget/window problem, over to you.
Assignee: jst → kmcclusk
(Reporter)

Comment 5

19 years ago
The problem has gone. Thanks. No asserts in a Win98 debug build from 2000.04.13.
Great.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

19 years ago
Verified. Problem not any more.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.